VR not recognising / starting in Studio

Every time the user has a VR headset connected, and tries to play in Studio, the VR integration does not work at all

This has been a really critical issue in preventing people from messing with their VR games - no ability to debug (dev console not visible), broken bindings, motion sickness problems from camera glitches, Vive lack of support all stacks up to make VR unusable.

The following users also experienced this issue:



Yesss a Top Contributor picked this uppp. I would love to make a VR game in Roblox like it would be awesome but for the past 5 or 6 months VR hasnt worked at all in Studio. It would be so awesome if they could try to fix this soon. With the new Valve Index out VR is getting popular again! And Id like to make a VR chat kinda game. But its literally impossible to work on VR games in Roblox at the moment. It only works in the 32Bit version of Studio, not the 64Bit. I have no idea why but that seems to be a thing. Also if you press F6 it will completely close your studio(Only when working on VR)… Learned that the hard way with a miss-click.

But thank you for moving it to Studio bugs :slight_smile: I would like to see if this could possibly get solved.


Is there no progress on this? VR is obviousley a hit thing on roblox with several games reaching thousands of players. Such a shame nobody can actually develop it effectively.


It may have been fixed I havent tried it in a little while. If games have been getting created then I assume it must of been fixed, because previously it was impossible to develop VR games.

1 Like

Bump, still a major issue for me

1 Like
1 Like

Wanted to make a vr game just now, after upgrading to windows 11. Roblox recongizes my headset and starts in VR, but studio doesnt. Im using an oculus quest 2, i tried the oculus software and steamvr, but nothing worked.


This is still a problem, I even added roblox studio beta and the launcher exe’s in the Oculus software, still not working, it does work with the roblox player itself though, i’m using a Oculus Quest 2.

1 Like

helloooo is any staff gonna respond to this??
It doesnt launch with air link, and it also doesnt launch with steamvr

1 Like

still a massive problem and roblox needs to fix this,
I wanted to make vr movement software but all of a sudden this started happening
roblox player, fine.
roblox studio, black screen.
I have a base oculus quest and was just using the oculus software
Roblox please fix this, I’m begging you all

1 Like

Update for me:
It works, kind of… When I run it in the test mode thing and not just the play button, it does say VR is enabled in options, but it just doesn’t work.

1 Like

after all this time do you have a solution for this problem?
When i try to test the game by going in to the “TEST” tab and press “Start” it tries to start the server but crashes the only way i found is to publich the place and use the in game consol by pressing “F9”.

I think this is now an issue in the main Roblox client now