Why does it jiggle?

Press F8 (or run) and watch it jiggle. Why does it jiggle? I want to make a car out of four of these wheel modules, so I need it to be very responsive and the torque to be quite high. I suspect it possibly has to do something with the alignment of the attachments?

File:
WheelJiggle.rbxl (52.2 KB)

Video preview:

This is a super simplified version from my car to just this module. It doesn’t jiggle initially, but when I change the value when I steer (either through a script or in this case just the properties tab) it starts to jiggle uncontrollably. Thanks!

4 Likes

There’s a couple things you can try:

  1. You may need to increase the ServoMaxTorque or modify the physical properties of the wheel to be less dense. There might not be enough force to support the wheel’s mass
  2. Add a NoCollisionConstraint between the wheel and the body of the vehicle to make sure Roblox’s collision physics aren’t potentially interfering with the servo.
5 Likes
  1. I increased the ServoMaxTorque to 9999999790214767953607394487959552, and it still jiggles :c
  2. Reducing the density isn’t an option, as that’ll be quite important for tuning later.
  3. Both the axle’s and steer’s canCollide are disabled, so no collisions are happening

Sadly nothing fixes this issue… Thanks for the help though! :smiley:

1 Like

I’m noticing a hinge for steering, so I suggest you try using a PrismaticConstraint instead of a HingeConstraint like the buggy uses in a recently added Studio template:

It might sound unrelated to your issue, but using a PrismaticConstraint might fix the jiggle problem

2 Likes

I looked into it, and the buggy is using a prismatic constraint to imitate a rack and pinion used in real life. This approach seems a bit too complicated for me… But thanks for the insight :smiley:

2 Likes

Can yall check how this works? This car’s steering has no jiggle…

Thanks!

Edit: The orientations are all the same… on my model, I tried to center all the attachments inside the parts, but that didn’t work


All have the same position:

1 Like

In the model provided, the axels are welded together and connected to the chassis using RodConstraints (the spring is also helping, of course), so the hinge isn’t the only thing responsible for connecting the wheel to the chassis

1 Like

I just spent about an hour in a test world doing everything I can to fix the issue… I can’t

However, in the main world (my game) it somehow works?!


The wheel and its children are all set to massless, and the servo settings are all the same, the parenting structure is the same… so why doesn’t it jiggle? There are no rod constraints holding anything together… so weird…

I’ve just spent another 2 hours in a test word, and I’ve simplified it to just this:

Why does one wheel vibrate, but the other one doesn’t?

Here’s the download link:
whyDoesTheWheelJiggle.rbxl (55.8 KB)

As far as I’m aware, they’re literally almost identical, apart from the attachments orientations, some of them have negative zeros instead of positive zeros. I’ve tried changing them to positive zeros, but they just go back to negative zeros. Otherwise, they’re exactly identical. Thanks!

Have you considered what happens when a driver hits something with a wheel?

It happens all the time in games; and at very high speeds.

I crash tested the buggy in every way I could think of; I was never able to get it to break.

I highly recommend stripping down the buggy to it’s most basics elements and using it as your base chassis.


^ This happens :rofl:

But seriously, I’m trying to make my own chassis, specifically this way (for a multitude of reasons that I won’t go into because it’ll take too long), and I’m just trying to figure out why the wheel is vibrating. I’ll fix whatever issues I’ll have with the car crashing physics later, right now I’m more focused on actually being able to steer :joy:

I’ll mark this post as the solution. I reduced the wheel density to 0.01 and it worked. Sadly this isn’t the solution I was looking for, but it was my last resort after 7+ hours in the test world. Thank you

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.