Blender Tip: Auto Smooth instead of Edge Split Modifier

When making optimized meshes in blender I usually get to these “curves” that I want to look smooth yet I dont want to add all the geometry. Adding geometry increases triangle count and makes your game lag etc.

For example, lets say I want this bend to look smooth

I could make the faces smooth by selecting the faces and going into Tools>Shading>Smooth. But the result looks terrible as seen below

Before, I would add the Edge-Split Modifier to the whole mesh and then adjust the angle so that it looks correct.
3

The result looks good but the edge split modifier creates these edges by duplicating the vertices! If you use this on meshes, your game could be filled with a lot of unnecessary vertices which can cause lag. For that reason you should never use that modifier.

I recently came across the Auto-Smooth option in the properties menu and it was a godsend. It creates the same effect without duplicating vertices.

6

This nice shading transfers over to Roblox too. You can adjust the angle to adjust how sharp or smooth you want your edges to be.

There have been a couple of times when I go to use it but the angle option is all blurred out. To fix this, you need to scroll down and under Geometry Date, there will be an option to “Clear Custom Split Normals Data”

Hope this little optimization tip helped! and Happy New Year to some of you

27 Likes

This doesn’t seem to actually have any performance improvement in Roblox. I exported it back to an obj from Studio after importing it into Roblox and the edges suddenly became split. The Roblox mesh format likely does not support custom split normals data, so it must split edges instead.

1 Like

Also in edit mode (in blender) you can make individual faces smooth or flat too, if you don’t want to the smoothness to apply to the whole object.

2 Likes

All exported OBJs have duplicate vertices for every face, so I don’t know if it actually performs that way internally on Roblox.

1 Like

Those duplicated vertices actually occur naturally. Previously when you imported a mesh to Roblox, the vertices get duplicated. It was a bug that they were never quite able to fix. Now roblox de-duplicates those vertices, so in the game the vertices are not duplicated. Its when you export to blender is when they duplicate. This discussion can be found here

@Crazyman32 When you simply use the smooth shading option on particular faces, the shading looks terrible. This is what it looks like in roblox.

8 Likes

With smooth shade you can do a ‘Clear Custom Split Normals Data’ to get rid of the shading bug.

Press Ctrl + Space and type it in the space bar for easy access.

1 Like

I’m pretty sure all faces are triangulated before being rendered. The only reason not to do it yourself is to make working on the model easier on you, b/c triangles don’t always interact well with loop cuts, extrusion etc.

3 Likes

For anyone using cinema 4d, this is basically adjusting the phong tag: image

and here is the difference

No Phong

and here is the result with angle of 80 and edge breaks off (you want to adjust the angle depending on the model)

With Phong- Edge Breaks Off

4 Likes