Character animations cutting out in bursts

This has started occuring in our game recently; animations playing on our character rigs will cut out to a t-pose and then snap back on. In this above video, we have an “Idle”, a “Jump” and a “Movement”. The “Idle” is always playing/looping at a low priority. Movement sits one priority above, and Jump at highest.

I can consistently re-produce this issue in our studio build. We are also recieving bug reports from users that this is happening in game. Nothing changed with the way we do animations code-wise. Additonally, the Idle animation is looped and is always playing, yet we see the animation cut out entirely, which is extremely odd behavior.

I am at a loss for exactly what is going on, so any assistance is appreciated!


Seeing the exact same thing in my game with custom characters. I use an older forked version of the R6 animation script with tweaked constants.
Animate.rbxm (6,9 KB)

It was like the idle animation just snapped back to max priority as soon the character landed after jumping while walking.


This is also happening for my creatures where an animation just stops randomly, this appears to happen whenever i do animation play:(0.5) instead of just animation:Play(), though i was not able to replicate this in studio.

1 Like

Exactly the same issue with our game and also started some days ago. This should be addressed as soon as possible because it’s making the game look so bad.


This is also happening for my game, several animations will cause T-pose flickering, and when using the fade in property for the :Play() function it seems to cause a weird delay and worse flickering. Hopefully its fixed soon

1 Like

Players in my game also started randomly flickering today and I have not pushed any new update in the past week.

EDIT: The issue here seems to be caused by the default Roblox walk animation. Deactivating the Animate localscript makes the character stop flickering.

EDIT: Nevermind, I believe my issue was not related to what is being reported in this thread. Just wanted to say that a roblox update had undoubtedly an interference with this.


I am having this issue as well. It usually occurs when triggering stuff like jetpacks or ziplines - unnatural character animations tend to break the natural ones.


Seems like this is the same bug: Animations don't work as intended in studio on rigs if they have keyframes assigned to parts of the player's real character

Same issue here, in studio as well as mobile.
Also happens with custom motor6Ds that arent even being overwritten by any other animation. I use a custom walk anim as well.

In our case, we specifically avoid using any elements of the real character / R15, i.e part names, to avoid any behavior overlap nonsense.

We repro this bug easiest in studio for some reason but it happens in-game. We eliminated as many factors as we could (i.e speed, weight, fade in/out), and broke our animator down to playing and stopping animations, and then we observed the state carefully. Animations that were definitely :Play()ing would not display, multi-animation running would behave weird, etc… So we really don’t have any good options :frowning:

If possible, try disabling any kind of fadein/out/etc and see what results you get, though!

I’ve got the same issue, in my game Valour, when we equip the tools, crouch, the animations will be glitching (i have no clues) :slightly_smiling_face: ,
and i think it’s from the lastest roblox update, hope this will be fixed soon.

1 Like

I was able to temporarily work around this issue by reverting the animation version to somewhere in 2022 (I believe it was May). However, I have no idea why older animations work properly while newer ones do not.

Can confirm this is also happening in my experience as well with two animations. Started about 3 days. Weird thing is that it only affects two of my animations which were made this month. I tried testing out some older animations in the same experience, and those worked fine and as intended, it was just the two animations that I’ve made this month.

I also tried testing these new animations in an empty baseplate, and they also did not work there either.

1 Like

I also noticed this issue in my games. I haven’t been able to replicate it in game however, only in studio… Lack of testing may be why.

Here I thought I made a mess up somewhere! Good to know that it’s just average Roblox animation shenanigans… Yippeee…

1 Like

Can we get staff ack so we know if this is on someone’s radar?


Just want to mention this seems much worse on some character models than others and is affecting the game in production. This is borderline gamebreaking. Comms please.


Wondering if this is the same issue. This is what is happening (sort of) in my project and it looks to be about what is occurring in OP’s project as well.

If that’s the case, then it looks like Roblox will release a patch for it in the next update, however still would’ve been nice if a staff member communicated this to us on this post, as I feel like this post is still more relatable to my issue than the other post I linked above.

Communication would especially be appreciated if the two posts are talking about different issues with animating, since like you said, this is game breaking and I’m unable to use any new animations I’ve created.

Looks like the same issue. Comms 4 hours ago on a patch getting fast tracked. :pray:


Thanks for your feedback!
Can anyone confirm whether the patch addressed the issues they encountered?


Thanks for your feedback!
Does your game involve a mixture of R6 and R15 parts and animations?
We made a recent patch (569.2) that addresses an animation issue that arises in this circumstance


I see that my issue is now resolved.