Failed to create key for elevation policy

Reproduction Steps
Launch Roblox Studio from the website or Windows search.*

*Personally doesn’t happen through Windows search as I have the shortcut set to run as administrator (see workaround).

Expected Behavior
Studio should be capable of launching normally on Windows 11.

Actual Behavior
Studio prompts with an error message reading “An error occurred while starting Roblox Studio. Details: Failed to create key for RobloxStudioLauncherBeta.exe elevation policy: Access is denied.”

image_2021-12-05_134637

Workaround
The only workaround so far seems to be modify all the shortcuts and executables that launch studio and setting them to run with administrator. After this, the error goes away until the next update, however this is a tedious workaround.

Updated Workaround
You can attempt to uninstall studio and reinstall it without accepting any administrator permissions. Track down all Roblox Studio executables (.exe) and delete them manually. Grab the most recent installer and attempt to install with that. It seems to have fixed the issue for me. This will ensure it installs into your user rather than into a system folder. Copy any additional files that you may need such as plugins if they do not exist in the new installation. Uninstall through the Control Panel if the issue persists and repeat the above steps.

Issue Area: Studio
Issue Type: Other
Impact: Very High
Frequency: Often
Date First Experienced: 2021-10-15 00:10:00 (-06:00)
Date Last Experienced: 2021-12-05 00:12:00 (-07:00)

sysinf.txt (2.4 MB)

40 Likes

To not get this error, never run Studio/Roblox Player as a admin at all because once you do, it installs itself to Program Files (which is why you will end up needing elevation every update/using launcher once launching either as admin once)

This is however still a bug.

11 Likes

Thanks for helping me triage this. Yes, if you run the launcher as an admin, it’ll install it into the Admin’s AppData folder, not yours.

It will also try to read from the admin’s registry which regular user cannot do. Theres where the “key” error is coming from

9 Likes

Studio requested administrator permissions to originally install. This is where the issue originally came from. Every update and reinstall have also required administrator privileges regardless.

4 Likes

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

7 Likes

What are you saying, I’ve run Studio as admin and it fixed this problem, I had the same exact issue.

2 Likes

They’re saying this issue occurs only when you run Studio’s installer as an administrator.

1 Like

I am having the same problem:
image

This came up after trying to install a plugin, and every time I tried to install the plugin, it popped up.

At this time, I can not download any plugins, roblox pls fix this.

I hope this helped. :upside_down_face:

10 Likes

Using RobloxStudioModManager apparently bypasses this issue.

3 Likes

I sign out all sessions of my account, so I have to rejoin in Roblox Studio. I fill the username and password and it takes me to the page that return me to the Studio, re-opening it, and when it is re-opening it gives this error.

1 Like

To install plugins you can simply force the program to automatically run as admin.

To do this right-click on your roblox studio shortcut and select “Open file location”. Then right-click on the highlighted app (RobloxStudioLauncherBeta) and select properties, select compatibility at the top, and tick the box next to “Run this program as an administrator”. Then just click apply, this should fix the problem temporarily until a more permanent solution is found.

21 Likes

This happens on Microsoft Surface Go 2 Windows 10 for me.

The issue also happens on the go one and most windows 11 computers

2 Likes

I also have this issue - Windows 10… I was using studio just today, and left it open for a while unused. Closed it, shut off the computer, and came back a few hours later to this error message. Not very happy about this, because while I’m not a great developer, I enjoy doing it and wanted to continue a project.

Edit: A workaround that has worked every time for me seems to be right-clicking my desktop studio shortcut, opening the file location, and starting studio from its file instead of the shortcut.

6 Likes

what if you already ran roblox studio as a admin

1 Like

nevermind i just reinstalled!!!

Completely reinstalling Studio does not fix/change this. I’ve tried just nuking my entire Roblox folder, still throws this error after a reinstall.

Instead of launching the shortcut Roblox created it, try running the RobloxStudioBeta.exe

Use RobloxStudioBeta.exe
instead of RobloxStudioLauncherBeta.exe

EDIT: Try using Roblox Studio Mod Manager. It’s 100% safe

6 Likes

a workaround I found is setting the exe and shortcuts to “RunAsAdmin” so you always get the run as administrator popup before studio launches.

Ive recently been having the same problem too and it’s really frustrating me. I’ve tried troubleshooting the problem two times and experiencing the same issue again. Is there a different way to resolve this?

1 Like