Game Ratings Not Saving

Update (6/11/2022): Although I cannot reproduce, some users are unable to rate games in any capacity. Impact changed from low to very high, and bug title changed from “Game Ratings Not Visually Saving” to "Game Ratings Not Saving"

Update (6/10/2022): The issue has not been resolved as I had thought. Visual ratings appear to save correctly on games that have been liked prior to this bug. Newly rated games from 06/09/2022 and forward will experience the issue.

Update (6/10/2022): This issue has been resolved as of 06/10/2022

Reproduction Steps

  • Navigate to any game
  • Play and leave game
  • Either like or dislike the game
  • Refresh page

Expected Behavior
Game page should provide visual confirmation for rating left by user.

Actual Behavior
Upon refreshing the page, the visual thumbs up or thumbs down icon disappears. Please note that the submitted rating is still counted towards the game. See update 6/11/2022

Issue Area: Roblox Website
Page URL: All games
Impact: Very High
Frequency: Constantly
Date First Experienced: 2022-06-09 00:06:00 (-04:00)
Date Last Experienced: 2022-06-10 00:06:00 (-04:00)

19 Likes

I can replicate this, and have been experiencing this since at least May 26.

However part of what you describe (submitted rating is still counted towards the game) doesn’t seem to be true, at least as far as anyone browsing a games page can see. (I’m unsure if the rating is still counted internally on Roblox’s end or not and just refuses to display for anyone)

If I like or dislike a game I have never voted on before, the ratings refresh (and show their value at the time of voting) but do not count my vote. Re-voting the inverse does not add or subtract to either, and opening/refreshing the page in an incognito window shows no new vote in either direction.

A reliable way to show this would be playing and then attempting to vote on a game which is not going to have people actively voting on it (and showing ratings moving up/down upon the vote refresh), such as a default game on a new users profile.


Also, this exact bug has occurred previously. No idea what the cause was the first time, or why it’s happening again. Hopefully it doesn’t take several months to silently patch again.

3 Likes

Through my testing, refreshing the page does save my rating. The only thing going wrong is the visual confirmation not saving. You’re saying that your vote is not counted at all?

Yep, if I vote on a game the number shown will not count my vote in it (it does not change the amount, or for games that have lots of people voting all the time it does not count my vote in it) as if my vote was just thrown away completely.

Refreshing the page will still not include my vote, the only difference is the like/dislike button gets unhighlighted again as if I never voted.

1 Like

Strangely the behavior has changed for me. When I leave a rating, it does nothing, but refreshing the page adds my rating to the counts. The icon still never appears. It’s likely that the issue is influenced by other behaviors.

1 Like

This is ongoing with my game as well. It’s highly irritating, I’ve paid in thousands of Robux recently to advertise my newly launched game, and no one is able to “Thumbs Up” the game, but “Thumbs Down” works fine, so now my game is sitting at a 52% as no one is able to like it. Aggravating and would like some sort of resolve. Been happening since June 2, 2022.

1 Like

Yep, I can reproduce. I’m not sure if it’s actually liking the game, but it seems ot have reset once I refreshed.

Game: https://www.roblox.com/games/7074772062/Speed-Draw

Also, I would up the impact on this to High, because it seems like it’s not counting the vote at all.

EDIT: Yep, it’s not saving, here’s a video of it.

1 Like

Also, I would up the impact on this to High, because it seems like it’s not counting the vote at all.

Will do. Not sure if it will update on Roblox’s end though, since they likely have automation to triage bugs upon creation.

1 Like

I remember some people were saying that they couldn’t rate games a while ago, but I could still, and now it seems as if it’s broken for a bunch more people now.

Hello, Just Noticied that with My TrelloAPI Model, Visually it also removes likes

2 Likes

For me, instead of ratings not saving, ratings don’t appear for me at all, instead throwing a ‘something went wrong’ error at me so I cannot view or make a rating at all.

It might be resolved but as of this week i have not been on the Roblox website so I’m not sure if it’s fixed or not.

1 Like

Great example of this inconsistent behavior! I’ve not heard of or experienced this particular variant.

1 Like

I received this exact same version of this bug (ratings were stuck at the same number, even after clicking) when attempting to dislike a game, after a few hours my dislike was counted however.

1 Like

Thanks for the report! We are investigating the issue.

3 Likes

It definitely seems like there’s an overlying problem with configuring experiences/unresponsiveness from the website.

The issues seem to be similar in the sense that a lot of game pages whether from a player perspective or developer perspective, are unresponsive.

From observing the recent website bug reports on the forum, there are reports of game titles/descriptions reverting to a previous version if modified, game ratings/favoriting being unresponsive, unable to remove thumbnails from games due to invalid permissions even if you are the owner of the group/game, unable to remove/modify badges, unable to remove social links, video thumbnails immediately play even if not on the experience screen (and if there’s two, they play at the same time), etc.

You guys are likely already aware, but it sort of seems like all of these smaller issues are potentially related due to one larger issue at hand.

Thank you for looking into this, we all appreciate you guys fixing this.

1 Like

From what I noticed… i CANT like/dislike experiences from my Roblox accounts that was warned or temp banned.

  • I have no problem to like / dislike an experience on an account that has NO warn or ban.

i thought this was a “Punishment” from Roblox…

2 Likes

This is starting to get annoying. It’s been almost a month already with no follow up from roblox.

3 Likes

On the last time this happened it took roughly 4 months to be patched, and even then it had zero word (and potentially zero intentional changes) from any official Roblox related users (staff/DET/devs/etc)

I really hope this genuinely urgent bug doesn’t get abandoned with no word like last time, with them hoping that it fixes itself.

2 Likes

This bug has been happening for almost 3 months now, literally over a year now if you count when it was first seen. It has been 2 months to the day since we got any word on this occasion apparently being investigated.

It took 4 months for it to silently fix itself last time with zero word (and because of it I can only assume zero input from any devs), I would rather that it actually gets worked on this time instead of being left to rot until it fixes itself.

Is this just going to be a regular cycle of some funnyman over at Roblox HQ flicking the “do not allow rating” switch every few months?

Do you have any updates on the this issue? It is still ongoing and heavily impacts user experience.

1 Like