Improvements to Object Insertion Workflow [Beta]

As of this week, we have officially released an open beta for improvements to inserting objects in Studio. We understand this flow is critical to how you work, so we created this initial period to encourage raw feedback as we iterate on this over the next 3 months.

Roblox Studio has evolved over time. With each iteration, we strived for something a little new, and attempted to do our best to make your life easier. With this iteration, we hope to do the same.

I’m going to shake it up a little bit here… I am not going to tell you or show you what we changed. Instead, I encourage all of you to go out there and use this feature so we can get your raw feedback. In the official announcement post, I will outline exactly what we changed just like any announcement post we have done in the past, but for now I’ll let you explore.

HOW TO ACCESS:

  1. Open Roblox Studio
  2. File Menu > Beta Features > Insert Object Streamlining

Enjoy!

As a little treat, here is a blast to the past as a reminder on what we had yesterday, and what we have today.

Pre-2013: Insert > Object > Modal

2013: Basic Objects
Objects available for insertion depended on the selection

Today: Advanced Objects
All objects were available for insertion, no matter the case.

Today: RMB > Insert Part/Object

Today: Explorer > Hover > Plus Button

Massive shoutout to @chilliflakes19 and @PoshKiwi for making this happen.

Happy Holidays to everyone, from Studio Team. We absolutely couldn’t be here without you and we can’t wait to hear your feedback. Here’s to 2020!

97 Likes

This topic was automatically opened after 16 minutes.

Great feature, really love this! Does this also work with models from the catalog though? If so, I’d be ecstatic that I can now insert my free models faster!

6 Likes

Works really well, I love it!, I have some sort of issue, this issue repeats after this Beta feature. The issue is that item text cuts off in half in the explorer. Can be this feature creating such as this behavior?
@nsgriff

Capturwfwefwefe

6 Likes

I like that this change has made the insertion of objects consistent whether you chose the plus button or RMB+Insert Object, however, for users like me who still decide to use RMB out of habit - I feel this may force me to start using the plus button as it’ll slow me down as it’s in a different position. Not only this, but not all objects are quickly visible without additional searching or use of the new Insert Object panel.

I should probably be using the plus button anyway, but I still use RMB out of habit. I do like the prompt that states that objects aren’t usually placed in certain areas, that’s pretty neat.

Additional functionality request: As the current behaviour for the “Frequently Used” menu currently just displays a generic list of items that are commonly placed into the objects of the class selected, I feel it’d be nice if it actually adapted to display objects that the studio user frequently places into the object of the class selected instead. See a few posts below, it already existed - I just didn’t give it long enough to show!

EDIT: Selecting “WorldModel” from the Insert Object panel (and from the dropdown menu) gives undesirable behaviour, displaying this message:
image
It’d probably be best if it didn’t show up, or at least doesn’t close the panel.

4 Likes

I feel that this new select to insert slows down the studio workflow as it’s moved up in a different section and feels a bit weird going to insert object now. I’ve also gotten into the habit of quickly being able to hover over that spot and select the object, but now we have to think about what we’re inserting and click, not a quick hover anymore.

1 Like

Small bug: CTRL+I shortcut seems to be broken. Please buff.

3 Likes

I love the fact you can actually add invalid instances to objects now, very useful instead of having to insert it somewhere else and reparent it.

However, the plus menu window looks messed up / clipped. Is this intentional, or just a bug?

image

5 Likes

@Daw588
That could be a bug. Please edit a screenshot into your post with steps to reproduce. Thank you!

@popeeyy
Can you go into more detail on your post? Is it information density?

@ee0w
Make sure you don’t have a pop-up currently enabled. Please post repro steps if this is happening.

@fireboltofdeath
That looks like a bug. Let me know if this persists!

@General_Scripter
What benefit do you feel like the entire object list being available provided? Is this use case solved by having the entire Insert Object widget opened? The goal with this feature is not to force you to use one or the other, we are trying new things and making every workflow behave the same way.

As for your additional functionality request… Just keep using it :)…

WorldModel will be removed with a change.

3 Likes

The whole section is moved up from where it used to be and it makes me sit there for a second trying to remember where it went. The menu is exactly the same as the menu I could just click the + button for, which I didn’t like in the first place so I used insert object. Hovering over was a lot easier to just look at everything at once rather than a big screen to scroll through everything. This had the same effect as just removing the option in the first place.

1 Like

I can confirms this happens consistently for me. No matter what, if you attempt to press Ctrl+I after selecting the plus button, you don’t get the “Insert Object” pop-up.

Also, I noticed that as the search results cap at a maximum of 7. Previously, it’d show all results with a scrollbar - I feel the new way actually slows insertion workflow, especially for value objects where you’d now have to specifically search for ray, string and vector values.

Images to show the thing mentioned above

New:
image
Old:

I assume you’re hinting at it already doing what I suggested - which is great! However, many sparkle inserts later I still fail to see it on my “Frequently Used” list.

Woohoo, this is great!
image

Never posted a proper repro because it’s so simple, but here goes:

  • Step 1: Right-click somewhere in the viewport
  • Step 2: Select “Insert Object…”
  • Step 3: Press Ctrl+I to access the See All menu

Expected behaviour: The “See All” menu should appear
Actual behaviour: It doesn’t

This would be more useful if I could press ‘Space’ to quickly open the insert menu for the selected object and begin typing, without having to to right click and find the button in the context menu

1 Like

@ee0w @General_Scripter
That’s a bug with how our widget system looks at that menu. Making the menu disappear will allow Ctrl/Cmd+I to work again.

2 Likes

It’s not entirely obvious that it’s a global keybind imo. The placement sort of suggests that it’s local to that particular widget, and at first glance I expected it to open a full-size list similar to the non-beta version.
Maybe I’m just a special snowflake. /s

Before, I had a perfect workflow with inserting objects and manipulating everything, with both RMB and plus icon.
Now, I have to go through an entire process.

If you want to keep this, I recommend you have the insert object menu on the side all the time, that way it’s a one-click-go kind of thing. THEN, I think I could enjoy it :slight_smile:

EDIT: I’m not exactly talking about the advanced objects feature. I’m talking about having the context to the insertion at all times.

As someone who only ever uses Advanced Objects and isn’t interested in the other methods, I have to say I’m liking the facelift. All the functionality from the old version is still there, and the idea of darkening incompatible objects while still not preventing the user from adding them is a nice touch.

My only complaint would be that the padding between each object feels a little large relative to the rest of studio, and a “Compact” option (similar to Gmail) would be great for packing more info onto the screen without me having to scroll down.

Overall, nice job team!

1 Like

This feature seems okay currently, but EDIT: Oops, wasn’t on the beta version. I’ve been getting confused lately since beta features are enabled or disabled by default seemingly randomly :wink: So the following hidden text doesn’t apply.

I have one major problem and that is how it limits us in what objects we can create based on the parent. I would like to be able to create pretty much any type of object anywhere, but the new tool doesn’t allow that. Right now I am trying to create a part in ReplicatedStorage, for example, and it won’t let me so I need to go into Workspace first, then move it.

Maybe this is useful for people who are using Roblox for the first time and don’t know where stuff is meant to go, but for more experienced users it is just a limitation. I quite often put objects in places for storage as placeholders or whatever.

Also, more advanced objects like Motor6Ds, Welds, UIGradients, etc. are not being shown – I was just talking to one guy who was rigging and he was complaining how the only way to insert a Motor6D is to use the command bar (or a plugin).

Can we at least get some sort of ‘advanced’ toggle that lets us see and insert these things? If this aspect does not get improved I will probably just stay with Advanced Objects since it’s reliable, capable and already ingrained in my habits.

2 Likes

You can insert Parts under ReplicatedStorage, even if the text is grey.
I don’t think there has been any narrowing of functionality. If anything, this is more functionality than the old UI, which didn’t even show you Part as an option.

image image

I’m still disappointed by the lack of Motor6D and other classes in the Insert Object / Advanced Objects widget, though. Please Add Motor6D & others to Advanced Objects panel.

5 Likes