Minimap Render [RoRenderV3]

It’s not the map that is too big, its the output image.

The image size limit is roughly 10k x 10k pixels. Your output image at a resolution of 1 is equal to the size of your map. Turn down your resolution in order to shrink the output image size.

How the output image size is calculated

local MapSize =, 5752, 41521)
local Resolution = 1
--Output image = {MapSize.X * Resolution,  Resolution * MapSize.Z)

Reduce the resolution setting down until it can fit within that size limit

1 Like

Very cool indeed!

Im trying to render my map but I just get this error when I click run. “Workspace.RoRenderSettings.Render.Actors.ComputePixels:90: Script timeout: exhausted allowed execution time for the current resumption point - Server - ComputePixels:59”

Anyone know a fix for it?

1 Like

Tried using this 6 times, but it constantly freezes at 12%, no errors pop up nothing.

It speeds up to 12% in the first 10 seconds and then freezes for the remainder. I made sure to wait 20 minutes to see if it was just loading but nothing.

Not sure what I am doing wrong.

Go into the script, learn how to use the settings and set the (RoRenderSettings.Resolution = 1;) to RoRenderSettings.Resolution = 0.25;

Thank you, I’ll give it a test and see if I get better results.

is it possible to have vision cones?

What is a vision cone? You’ll have to elaborate some.

Same error, stops at 7% on a big map.

1 Like

I have discovered that if a union is max part size, and if the meshes unioned go out passed 2048 studs, it causes this error. I was able to get further along before it errored out again.

This has worked for me in the past, however if you look at the top, you can see how some hills have sharp edges, this is what use to happen instead of erroring out.


Lowering the NumActors value allowed me to not crash.

1 Like

I can’t run the program on Mac.


Uhhh my map doesn’t look quite right lol

Not even sure what i’m looking at

I’m constantly getting a
Script timeout: exhausted allowed execution time for the current resumption point
error. No matter what I do. The map is pretty sizeable, but I don’t think that’s an issue. Any idea what I’m doing wrong?


I actually fixed this right away by simply lowering NumActors, I forgot to share that. Thanks for replying anyway.

How is this so good, I looked at results people posted here and holy cow the images look amazing, if i make a game with a mini map im deff using this.

1 Like