"Modern Studio" (new docking behavior) has various issues

This has to be fixed ASAP, I’m literally not being able to work because of it. When I try doing a test with 2 clients all the windows get messed up and I have to keep re-starting the test 10-20 times until it works.



It’s sad to see so many people having this issue. I am fortunate to now have these specific issues at the expense of Roblox Studio crashing upon closing (Which originally also crashed when opening the What’s New menu and Insert Object. Those are mostly fixed for me).

Roblox, we need the patches really soon as this is really concerning.


I’ve given up. Opened studio to look at the big project i was working on solo and immediately felt disconnected from it and discouraged. Being away for a month has made me forget my workflow.

It’s crazy how i can use a cheap laptop and my project doesn’t freeze in studio but on my gaming laptop it freezes and now the http 500 error loading assets. The first bug wasn’t fixed.

Well, it appears they have D3D11 render working again but that didn’t prevent the freezing and im wondering if it has anything to do with OOP since i saw a recent post about something related to metatables being bugged. Who knows at this point?

I’ve since started learning c# and unity. I also use my Lua knowledge in other game engines. Roblox only seems beneficial for major studios who have already got a leg in the door and have made roblox lots of money. Everyone else… well we see how it plays out.


Do you have a custom cursor size? Is your display scaling set to 100%?

1 Like

I have no custom cursor size and my display scaling is at 100% at 1920x1080. This issue was on both of my PCs (A desktop with a single 720p screen and my laptop that I always use that’s 1080p), so it has nothing to do with multiple screens or screen sizing for me.
Here are all the specs that I currently have in my bug report about this:

It only occurs on Direct3D11 for me. I since swapped to Vulcan, which runs faster on my PC as well as also have no issues at all. The only issue I currently have is that Roblox Studio is way laggier than the Roblox Player when it originally had nearly the same framerate with Studio being slightly slower (which that was understandable).

1 Like

I was going to open a bug report for exactly this reason, but I see this is already reported.


Thanks for your feedback!
As per my post above, I suggest to do a un-install/re-install to unblock yourselves @IDoLua @bitsNbytez @AstraI_YT @lineridermasterman @ShinsokuDev.

By doing an uninstall/reinstall you wipe the layout settings previously saved and delete whatever corrupt layout you are on. If you continue to face the issue after an uninstall/reinstall, please DM me directly.

However, if you are using the Mod Manager, re-installing may not clear the layout. In this case, you must follow the post here "Modern Studio" (new docking behavior) has various issues - #58 by GeneralRelish

Beyond this, I will follow up again after the next patch to understand if our fixes have effectively fixed your corrupt layouts.


In my case ("Modern Studio" (new docking behavior) has various issues - #81 by rogeriodec_games) this does not work.


@ElephantMesh just to be clear, about the Draft Window being always open beside script editor, despite moving it in previous Studio sessions:

  1. Studio always open it this way:

  2. You move it like here:

  3. But in another section it will return to its original position (1)


I can confirm this is happening. Really a huge issue they need to fix with docking

1 Like

Im now having an issue where the viewport is just purely grey, closing the place / closing studio does not help this is a complete and utter joke. Oh and I can no longer drag the viewport out (the old fix i found)


@ElephantMesh @Hauber_RBLX @DarkPixlz

I found out what causes the layout of the Draft window to be lost.
I opened a bug report:


From my perspective of never having disabled Team Create, I can tell you that it’s worse than broken:
It’s flaky. From the beginning of this new disaster Studio redesign, the Drafts window sometimes will
come back to where it was manually docked, and sometimes it will be in that odd location.

(You may find that your solution is really a phantom, as I mentioned, it has always been flaky.
Today I tested the Drafts window location at startup 6 times–Its location failed only on the 6th test.)

BUT, on my setup, the Drafts’ View setting (that I set as visible) is always lost on Studio startup, lost
along with the view setting of the Chat window as well (I always have to manually set them as visible.)


the new studio docking feature just seems like a rushed edit to “modernize” studio. It ended up just making docking widgets and stuff more complex and harder. I prefer the old system much MUCH more than the new current one.


Running a test server with 2+ clients still bricks the viewport:

1 Like

Hi, have you tried to reset your layout?


I have, and the issue still occurs.

1 Like

Issue still occurs to this day


1 Like

I’m not sure if it’s just me but the latest issue appears to have made the issue worse. Now, about 50% of the time, my viewport gets bricked with a single studio instance open, and while doing a solo 2-player test at least one (usually 2) viewports get bricked essentially 100% of the time.


So, I hadn’t actually been using studio until today; that’s why this is late.

I’m sorry to inform Roblox that they didn’t fix anything, in fact, it’s downright worse.

I used to be able to still use studio after the viewport “broke” and “crashed” but now when it breaks it crashes literally after I updated studio.

This is outrageous and if there isn’t a good fix for this buggy behavior (which might I note, makes development on Roblox nearly universally unfeasible,) there’s gonna have to be an explanation given as to why Roblox has been pushing buggy updates with very little quality assurance testing.

Anyways, some notes:

  • Apparently this is even more of an issue in some cases on Windows 11. I’m on Windows 10, no plans to upgrade any time soon, and it’s already bad enough on here. Can’t imagine this getting worse.
  • I run FPS Unlocker, not sure if that’d cause any issues directly, but it might; can never rule out possibilities.
  • My monitor does not benefit at all (from what I can tell) from the High DPI updates since I’m using standard 1080p (albeit at 144Hz)
  • Still not fixed, kinda furious ngl.