Most of my creation disappeared?

Hey everyone! Recently I have been creating a lobby for fun. But something happened that scared me. So I was taking a break for about a hour or two, and came back onto studio to keep working on this project to notice, EVERYTHING WAS GONE! But upon further examination nothing was gone, it was just all invisible! I can highlight all the parts that went “Missing” but cannot see them, they have 0 transparency and I am just stuck.
Any help would be appreciated! :slightly_smiling_face:
Sorry for the low quality, and bare with me. Its has been a long while since I have went full time in studio so I may not know how to do some things

Edit: I have already tried re opening studio, and tried reconnecting to my internet

1 Like

I’m guessing that everything that’s missing were unions?

1 Like

Yup! A lot of stuff were unions. Is there some sort of bug that effects them currently?

Hmmm, I believe I did this correct. I turned that on, closed out studio. And opened it back up and it still did not do the trick.

Just in case, can you check that it’s still checked?

Yup it is turned on.

1 Like

:confused: Hmm, well, you can try deleting Roblox’ temp files.

Alright, i’m currently backing up the folder first and ill get back to you as soon as its finished.

If that doesn’t work, the unions may just be corrupted due to issues whilst saving and will have to be remade. This is a common issue and the best possible solution is simply to avoid unnecessary unions. They are a highly problematical function on Roblox best used for necessary situations.

I hope XAXA’s solution works for you.

Yea that did not help either. I guess somnar might be correct :anguished:
I can probably mess around with a few things for a bit longer but if not i’ll just end up staying up and rebuilding it all.

edit: thank you for trying to help though, I do appreciate that :smiley:


Mind uploading a place containing one or several of the unions? I wanna check if they load on my pc somehow. If they load, then maybe they’re not completely gone.

Yea sure thing. Give me just a couple of minutes to do this

Do you want it as a file or just a game link?

A game link would work too. You don’t need to uncopylock it.

Here you go! I put 4 Unions in here.

Yeah, they’re gone for me, too ;_;

Noooo! Well this is sad. I really do appreciate you trying your best to help me though. I can just redo a lot of it. And this time ill be careful on what I union. :slightly_smiling_face:

They are corrupted. Nothing will get them back (oof). :confused:

Highly recommend sending a repro here so it doesn’t happen again:


Try exporting the union as an obj file to see if would load in blender or any 3D software, it it doesn’t export or load in blender, perhaps it is truly corrupted, however if it does load in blender, upload it as a mesh instead.

1 Like