[Opt-out Phase] Introducing Animator Retargeting for Supporting a Single Animation on Multiple Rigs

Would it be possible to upload a .rblx for testing this? And were you able to repro on a clean baseplate? I’ve tried to make places, upload them and the property changes seem to save as expected.

My speculation for now is that there could be some other factor related to the behavior as well. Or possibly a restart of game servers after saving and republishing is needed for the property to apply.

1 Like

I’ve been having this exact same problem with my Motor6Ds. I’ve set retargetting to disabled in studio and it fixed it, however publishing the game causes it to switch back to default when in an actual game. I’ve tested and it works in a test server, but just doesn’t work in a live server. I’ve went ahead and printed retargeting:


TEST SERVER same result in studio

So I decided to set retargeting to disabled at the beginning of a script before players load. Doing this did fix the issue in live servers, but I really don’t like this solution and am still confused why when it’s set to disabled in studio, it doesn’t save to live servers.

Ok big news, I thought about what @RayBloxSunshine said:

and decided to click “Migrate to Last Update,” (I’ve never clicked this button before) doing this fixed my issue completely and the retargeting changes in studio are now saved. I don’t know why this works compared to publish and shutting down servers, but alright. :3

I’m still a bit skeptical about the whole situation lol, but if anything happens (like it breaking again or something) I’ll update it here.


https://gyazo.com/1a74d5aab64c50b97465cc3317ab9626 why is changing lowertorso or uppertorso motor6d orientation cause these ? this cause a problem with my character tilting script ! and this only happen when i enabled retargeting … any idea ? is this an engine bug or something ?
this is without enabling retargeting https://gyazo.com/64aa6af762e80388c06c5fa76cc31f91


If this happens to be C0 or C1 getting modified, then either disabling retargeting or trying to use the motor6d transform instead would be recommended. C0 & C1 defines the way retargeting understands the rig, which should remain static for most cases.

1 Like

Hi, the videos in OP aren’t working anymore it seems. Could they be reuploaded?


We’re using the Opt-out option for Workspace.Retargeting because although the original animation rig uses the same Rthro scaling 1.0 Character rig as the destination rig’s scaling, the Animation Retargeting system unnecessarily deformed the animation angles.

Workspace.Retargeting should consider the animation rig’s scale relative to the target, because in this case
they were the same rig (1:1 identical) and it shouldn’t have adjusted the animation at all.


I am using the opt-out option because on my regular R15 character (with some slight height modifications), the arms and torso act weird, whereas when Retargeting is disabled, everything acts perfectly.

Example with Retargeting disabled:

Example with Retargeting enabled:


Enabling retargetting causes my characters arms to stop inheriting rotation from their ancestors, in the video above i apply a rotation to the C0 of the root joint, and as mentioned in an above comment it’s recommended to use .Transform from now on, which I’ve applied to my game and fixed. but what will happen to old games that rely on modifying the C0 and C1 of the character during runtime? will they break? or do you guys intend to keep supporting animation retargetting disabled?

1 Like

What about NPCs? I could not get retargeting work on NPCs so I assume this feature is only for players.


I think this feature could be improved there are many packages which it is very buggy with such as the Woman Package, Man Package and a lot of Anthro Packages

This is how my gun is meant to look normally

When I equip the women package this is how it looks
The gun faces downwards and the hands overshoot not correctly gripping the gun (This only happens with retargeting enabled)

The retargeting is also not very precise for the Woman Package, Man Package and Anthro Packages however it works pretty well on other Roblox packages

I think this feature is important as I want to allow players to wear their own avatars without me having to remove their packages and set everyone to the default Roblox package for my game which players do not like


This is consistently breaking my game, which utilizes the Motor6D Cframes in scripts.

This in itself is ok, considering it’s ‘opt-out’ for now.
However, setting workspace.Retargeting to Disabled, does not save across sessions, nor does it publish to the actual Roblox place.

It would be great if this behavior was fixed :slight_smile:

(Visual of bug)

It’s annoying that this feature breaks games that simply want nothing to do with it (such as mine which uses an in-game R15 avatar customization), and can’t be disabled :slight_smile:


i guess what you could is just have a script that disables the option each time a server gets created

game.Workspace.Retargeting = Enum.AnimatorRetargetingMode.Disabled

In a server script


Ah I wasn’t aware that it was possible to set flags during runtime! Thanks I’ll try it out :slight_smile:

1 Like

I recently had a very similar problem to ConnectNot_connect (and what was posted here)

When adjusting a Motor6D joint’s CFrame while also playing animations, the animations wouldn’t adjust to the CFrame change (the expected behavior). If the setting were to be removed, that would be pretty problematic for my use case, and I’d most likely have to migrate my entire game to a CFrame only animation system.


I’m receiving issues with characters’ arms jittering with this feature when using Realism — Make your games feel more immersive!, this is a critical issue for my experience as it ruins the entire feel of my game


Hey, enabling Retargeting causes our game’s walk & run animations (presumably among others) to look far worse.
Retargeting enabled:

Retargeting disabled:

1 Like

The bent in arms is a known issue. We’ve implemented a heuristic to address it but are still improving the system to catch more cases. If you can provide a file for repro, it would be greatly appreciated!
In the meantime it should be fine to disable the feature until the problem has been fully addressed.

For context:
There is a misalignment between the blocky upper arm and the actual joint locations defining the “arm vector”. As the system tries to straighten the arm vector, it actually shows up as a bend in the actual mesh parts.

1 Like

Sure thing! I’ll PM the walking animation.
I’m glad to know you’re aware of the issue; I figured you’d eventually change from opt-out to constantly-enabled and figured I should report if this wasn’t made aware of yet, as it’s been affecting other developers also.

1 Like

Thank you! There is still a strong case for situations that won’t use retargeting so the disable option will remain available for the foreseeable future…we will make sure there is ample communication and discussion if there are ever plans to change that.


I had to disable this because it made my characters arms bend in, as well as breaking my procedural aiming by editing the joint C1s. Any new animation I uploaded caused the character to glitch out when I edit the C1s, but the old animations I had were fine.

I really wish this was not enabled by default because I had no idea what was going on for so long until I randomly found this thread which caused me a lot of issues.

1 Like