Pathfinding now supports Climbable Trusses

Glad you patched this bug out, it was pretty major. Thanks for working on the issue!

1 Like

I am wondering how we can tell if the waypoint is for climbing or not though. Since there is no PathWaypointAction for Climbing.


@oldmannt If you could make a feature request that adds PathWaypointActions for Climbing, use of Pathfinding Modifier (its label name AND the modifier instance), use of pathfinding link (its label name AND the link instance) that would be super appreciated. (I can’t do it myself for some reason)

Thank you for suggestion.
For now you can check the label for the waypoint, if the the label is “Climb” then this waypoint it’s for truss climbing. Does it work for you?

Ah yes this does appear to work. Labels aren’t super well documented on the API reference (It doesn’t mention the Climb label in PathWaypoint | Roblox Creator Documentation) so I had no idea this existed. I would still like a way for a waypoint to return the instance of the pathfinding modifier or pathfinding link it’s using though.


The trusses seem to break the navigation mesh on certain occasions.
Here is the link to the post I’ve made on it:

I can provide the repro in a private message.


This came out literally 8 hours after I completed a 3 week caffeine induced insomnia nightmare bug riddled god mode programming session where I made NPCs climb trusses perfectly.

At this point I had created a monolithic borderline self aware piece of unholy mess that worked for some strange reason.

Needless to say I started crying when I read the news that climbing was now one parameter away from normal path finding… My tears were from a peculiar mix of pure joy and utter resentment. How could Roblox so nonchalantly add a feature like this after all my hard work? But also, thank you, THANK YOU so very much for letting me delete my abominable hornet’s nest of spaghetti madness.

So… I deleted my golem of doom, my totem of curse. Good riddance, I thought, the wake will be a rave party!!!

… only to find out 2 month later that the truss climing flag to pathfinder that Roblox now supplies is a total piece of garbage. When I trace the path out by drawing balls at each path waypoint it looks like a toddler on drugs tried to draw the dots of a dalmation while riding a roller coster. (please see screenshot below).

So now I am scrambling to resurrect my nemeis again, the undying witch of pandora, the whirlwind of fire.

Please dear Roblox, fix this, lest my sanity will be a thing of the past.


This happens on terrain as well where there are random floating waypoints.


I’m sorry to hear that you encountered issues, we are working diligently to fix the bug as soon as possible.
In the meantime, could you please sent me a repro for this issue? Then I can figure out the problem easier.
We truly appreciate you bringing this to our attention and your patience while we work to resolve this.

1 Like

Thank you for reporting. Could you send me the repo for the random floating waypoints on terrain? It will be a great help for us to fix the issue.

1 Like

There isn’t really a repro place for this since it happens randomly and abnormally. However, the last time I checked the problem was much worse and you just get waypoints that are a few studs higher than where they should be:

Also, while experimenting with this I did find an issue with pathfinding. If the target is slightly below the navigation mesh, the waypoints will position to the lower point instead of rounding to the upper point:
robloxapp-20230110-2002145.wmv (3.1 MB)

Here is the place I was using for tests:
pathfindingRepro.rbxl (440.5 KB)


Just found out NPCs don’t appear to use trusses to climb down, resulting in them climbing to places where they get stuck (since pathfinding service avoids falling off cliffs). Hoping this functionality gets added soon.

ALSO there’s a major problem with the navmesh in enclosed spaces with truss parts as seen here:

Edit: It isn’t just that watch tower either, it can be recreated kinda easily:


This is also happening to me too. They seem to work effectively and fine, But it’s kinda annoying at times.


Hi! I am not sure what “repro” means?

I am pretty sure a repro is a roblox place file. They usually need these in specific cases when they can’t reproduce an issue by themselves I think.


yes, thank you for explaining.


Also, Since pathfinding is getting better, Would it be better if roblox can let us add our own navigation mesh for pathfinding, Would make it easier without adding pathfinding modifiers.

1 Like

They are a memory leak in PathFinding
Devforum post: PathFinding service leaks memory until it crashes the server
I’m reporting here in case

1 Like

OH! Someone else with this issue! The changes to trusses broke one of my pre-existing structures and navmeshes.

I filed a bug report with a repro model here:


Oh my gosh thank you for making a bug report for this! :pray::pray: I can barely figure it out and when I do I usually don’t get a response from the bug report team.

1 Like