Studio mouse turns into the inverted roblox pointer

So, theres this strange bug, where you open studio, and you load in a place, your mouse goes from your default PC mouse, to roblox’s cursor. To be more specific; the black cursor. Your cursor will only go to the roblox one, if its inside the studio work area.

The roblox pointer also seems to disappear if you go into game settings, and click cancel. But then your cursor will no longer go into the grab icon when you hover your mouse over a movable object.

This bug has only started occuring today (i wasn’t on roblox yesterday, so it might of started then)

31 Likes

Don’t know if it’s so much a bug. Yes, the cursor in the workspace is the black triangle, and out of the workspace is your standard cursor, but is that an issue for you?

And sorry, my English teacher is screaming in my head, “I wasn’t on Roblox yesterday, so it might have started then” lol

4 Likes

This is a bug; why would your mouse go from a standard PC like mouse, to the roblox cursor. Your cursor even changes to like the little grabby hand thing when you hover your mouse over a part. And the mouse will go back to the regular one if you press a studio button (like the game settings)

And yes, its an issue for me, just cause i don’t like having a big triangle mouse when im developing. And its weird hovering your mouse over studio buttons, or parts, than change to a more regular mouse.

3 Likes

I prefer the hand when the mouse is over something you can grab, so if I want to clear the selection in a crowded area full of Parts/Models I know when I’m over something that can be selected.
The black triangle icon isn’t that much bigger than the Windows mouse so it doesn’t bother me much.
I do use 2 screens so my workspace window is the size of one entire screen and my Explorer, Properties, Toolbox, Terrain Editor and Output windows are on my other screen.

2 Likes

Try deleting the camera instance in your explorer. Maybe that will fix it, but other than that, all i can say is weird bug.

1 Like

Nope didnt fix. This is roblox problem

2 Likes

yeah, maybe you should report that as a bug alone in #platform-feedback

2 Likes

Thanks for the report! This should be fixed now.

8 Likes

This is happening to me as of October 2020. It seems to randomly happen sometimes when I open Roblox Studio. It’s the same as the original post where it only happens in the studio work area.

14 Likes

Good to know others are having the exact same issue!

This has been happening since yesterday, at random times when I open a place I need to close it and reopen because of the cursor.

9 Likes

Same issue, but I can also select more tools in the UI for some reason
https://i.gyazo.com/fb97e0fc82e87b9a7ef695a57880e34e.gif

9 Likes

I seem to be having the same issue. Oddly enough, it only seems to be affecting a singular place of mine. I have the regular cursor in every other place and can move stuff around in those places.

I remember this bug before (around the time OP posted this originally). It was quite an easy fix for me, just closing and reopening studio seemed to work. Although this time while trying, it doesn’t seem to work.

In case more photo / gif references of the issue is needed, I’ve attached a link below.
https://gyazo.com/c6fa15f5d302746c628140a22be4507e.gif

5 Likes

If you open your place via the Roblox Studio app and not the Roblox website, then I don’t have the above mentioned issue anymore. Hopefully it will work for you as well.

However, this method won’t fix the actual problem. The ‘black cursor’ will appear again if you try to open your place through the Roblox website.

7 Likes

Opening a new place and overwriting it with your previous builds might help for now. I’m still not sure when will this be fixed.

3 Likes

Thanks for updating. This behavior is a new unrelated issue, tracked in these posts:

We are working on a fix. Please refer to the comments in those other threads for how to work around this issue in the mean time.
Thanks.

3 Likes

Hello,

This ties closely in with this topic here:

My cursor turns black, and most of my tools bug out as a result. You might find some helpful solutions in the thread that I linked above, hope this issue gets resolved!

3 Likes

I usually fix this bug by resetting all of my settings in the settings tab.

Hopefully that can work for you in the mean time!

2 Likes

Hi, it has been a few months since this post, it is still happening for me, it is really annoying as im trying to work on my game…

3 Likes

Yep, looks like this bug is back. I disabled my plugin, and re-opened studio. That worked, but now I don’t get my plugin.

2 Likes

Also been happening me for a few days, it happens sometimes but I just reload studio. I can’t reproduce the bug since I don’t know what I do before it happens.

1 Like