Studio mouse turns into the inverted roblox pointer

yeah, maybe you should report that as a bug alone in #platform-feedback


Thanks for the report! This should be fixed now.


This is happening to me as of October 2020. It seems to randomly happen sometimes when I open Roblox Studio. It’s the same as the original post where it only happens in the studio work area.


Good to know others are having the exact same issue!

This has been happening since yesterday, at random times when I open a place I need to close it and reopen because of the cursor.


Same issue, but I can also select more tools in the UI for some reason


I seem to be having the same issue. Oddly enough, it only seems to be affecting a singular place of mine. I have the regular cursor in every other place and can move stuff around in those places.

I remember this bug before (around the time OP posted this originally). It was quite an easy fix for me, just closing and reopening studio seemed to work. Although this time while trying, it doesn’t seem to work.

In case more photo / gif references of the issue is needed, I’ve attached a link below.


If you open your place via the Roblox Studio app and not the Roblox website, then I don’t have the above mentioned issue anymore. Hopefully it will work for you as well.

However, this method won’t fix the actual problem. The ‘black cursor’ will appear again if you try to open your place through the Roblox website.


Opening a new place and overwriting it with your previous builds might help for now. I’m still not sure when will this be fixed.


Thanks for updating. This behavior is a new unrelated issue, tracked in these posts:

We are working on a fix. Please refer to the comments in those other threads for how to work around this issue in the mean time.



This ties closely in with this topic here:

My cursor turns black, and most of my tools bug out as a result. You might find some helpful solutions in the thread that I linked above, hope this issue gets resolved!


I usually fix this bug by resetting all of my settings in the settings tab.

Hopefully that can work for you in the mean time!


Hi, it has been a few months since this post, it is still happening for me, it is really annoying as im trying to work on my game…


Yep, looks like this bug is back. I disabled my plugin, and re-opened studio. That worked, but now I don’t get my plugin.


Also been happening me for a few days, it happens sometimes but I just reload studio. I can’t reproduce the bug since I don’t know what I do before it happens.

1 Like

This issue is really bugging me, as it’s not allowing me to select anything in the 3D window and it won’t let enable anything in the VIEW tab. Also, for some weird reason, whenever I launch a game from the Develop page, it opens two studio windows instead of one.

A temporary fix I found is to launch studio independently from your OS rather than the website, then select your game.


That’s exactly what I did, can’t use my plugins now.


It works unless you have a universe game and need to open a new place form the asset menu. The starter game works but the second place within the game universe has the glitch, whether you open studio from your OS or not. They really need to fix this

1 Like

This is bugging too badly, I cant use studio for today cuz of that bug! Every time I log in to Roblox studio, this happens. Still happening in November 11

1 Like

The update that just came out a few minutes ago from when I’m posting this reply has FINALLY fixed this bug. (At least for me, and I’ve been having this issue since Mid November)


Create new bug reports for new bugs.