The InGameMenu UI appears dark with reduce motion enabled

PC Info: Windows 11, 24H2
Impact: Small
Frequency: Consistently
Date First Experienced: 7/11/2024

Reproduction Steps:

  1. Have reduce motion enabled
  2. Open the InGameMenu

Expected Behavior: UI should not appear dark. Only the background
Actual Behavior: The entire UI appears dark

Workaround: Disable Reduce Motion (for now)

9 Likes

After further research this seems to be happen because of a typo in SettingsHub.lua

This also only happens if you have reduce motion enabled

4 Likes

I was wondering when users would start noticing this >.>

We caught this error just a little too late on our release cycle this week, sooo it’s going to be present for a few days until we can get the patch up hopefully at the start of next week.

I’m impressed you found the error in the source! I wrote this code, and the typo was a dumb mistake on my part. Sorry about that!

The good news is that the menu’s functionality should not be affected besides the brightness-- though if you find any other unexpected side effects, definitely let us know.

13 Likes

Just felt like checking the script out of boredom lol

Guessing this was a fix for Bug with the new InGameMenu from the fflag name as i don’t think this was ever fully fixed (i never knew reduce motion would still mess with it)

4 Likes

Different bug, actually. I’ll check that one too though, I don’t know if it’s still around or not.

5 Likes

Setting the FFlagFixReducedMotionStuckIGM2 FFlag to true also seems to fix this issue temporarily

1 Like

That is true-- flipping flags is not officially supported, but that’s the one that’ll fix it.

3 Likes

For the love of god, fix the menu lag

image

3 Likes

Yes, I would like that this bug is checked too, since the performance problems on the menu are insane "SettingsHub" and "ReportAbuseMenuNewContainerPage" are Very Slow

1 Like

The fix is now live. Thanks for your patience!

4 Likes