This toolbar cannot create more than one button with id

Can’t find anyone whose reported this yet

For the past few days whenever I open studio I get these error messages


For plugins (seems every plugin I have has this error, so guessing it’s the same for every plugin)

All I had to do to recreate was just open a new place with the plugins I have (any plugin)

6 Likes

Please try to create a plugin that reproduces the behavior. I tried to load some plugins, including one that has several toolbar buttons, and I didn’t get this behavior.

It may also help that you list the plugins you have instead of saying “open a new place with the plugins I have”.

The error messages you’re getting in that screenshot are supposed to warn plugin developers that no two buttons can have the same ID on the same toolbar.

3 Likes

I got no clue how to make a plugin, nor what the error means.


3 Likes

Odd?? I have the waterfall, gap fill, and resize plugins, the same you have. I don’t get these error messages.

3 Likes

What if you disabled all the plugins you have and then restarted studio? If that works, enable one plugin, restart, enable another, and so on until you get an error. It might be that a plugin is being messy.

2 Likes

It’s every single plugin I have. Just updated them all, all are up to date. Disabled them all. Enabled one, opened studio, error shows up. Disabled, enabled another, go again, error pops up again. Did this for about half of them. Every single throws this errror.

Example of just one of them being active (not gonna go through all of them again and SS each one)

1 Like

I can’t seem to reproduce it. It may be that your Roblox applications are broken and need to be reinstalled.

I saw the IDs in your error messages were prefixed with “cloud_”, so it might be related to this recent development.

2 Likes

Someone mentioned that bug here


But a staff member replied saying they’ve reverted the changes (the solved answer) and this was months ago, so it shouldn’t be occuring now all of a sudden

3 Likes

Still errors.

This toolbar cannot create more than one button with id: “cloud_3550088966_BACKDOOR SCANNER_KRONOS”

plugin:CreateToolbar("BACKDOOR SCANNER"):CreateButton('KRONOS',"::Scans your game for backdoors or viruses::", Settings.pluginIcon)

Paste that code in a script, publish as plugin, change something in it and update the plugin, it will throw this error …

2 Likes

I’ve been experiencing the same issue for the past few days except it only happens in certain places.

1 Like

I’m getting this as well. As shown here:


EDIT: This bug happened to me when I installed Kronos, I’m not 100% sure it’s it though. Kronos is a plugin by @WhitexHat which removes backdoors.

I don’t have that plugin so it’s not that. I’m sure what @ForbiddenJ said about it being a cloud problem is correct. Just need to get the attention of staff

For me, it only happens sometimes with different plugins when starting studio. It sounds like the plugin loader is loading the plugins twice…

An easy reproduce is my plugin rip… Property Text V2, it happens every time I see it so far.

Even though this happens, all the plugins see to work fine. Although this isn’t critical, it would be nice if I wasn’t getting spammed with this message on start up…

Yea, I’m quite disappointed if it will effect my game. Now I’m not sure to continue my project in that game that it’s giving the output in, or to make a new game and transfer the gamepass purchases…

The errors won’t affect your game whatsoever. Nor do they cause plugins to break/etc.

The only problem with the bug is the spamming of the output on startup.

I’ve also been experiencing this issue recently.

I think I’ve found how to reproduce it:

  1. Grab some random plugins.
  2. From Roblox Studio, turn on Team Create on a group game.
  3. Close Roblox Studio.
  4. From the game’s webpage, click on the three-dots, and then click “Edit”.
  5. You get the error.

Here’s a picture of what’s happening to me. It looks like my plugin’s scripts are being run twice.

I think a fix that plugin authors can do for now is to put a BoolValue named “AlreadyRun” inside each of their scripts, and then set one to true as soon as a script runs. If it is already true, then don’t run.

1 Like

I’ve noticed this issue too. Although in my case it’s to do with the act of updating a plugin instead of getting them by opening Studio. I’ve gone ahead and even made a little video demonstrating this problem with a dummy plugin, with as simple-as-can-be coding.


Video Example


Coding Example

local ToolBar = plugin:CreateToolbar("Empty Test")
local Button = ToolBar:CreateButton("Button","WIP","rbxassetid://2195531164")
print("This is a test!")

plugin.Unloading:Connect(function() print("Unloaded!") end)

I believe this started happening around the same update that allowed for plugins to be independently refreshed instead of needing to refresh the entire list. I’m not certain of the exact version.

This also prevents the plugin function plugin.Unloading from firing, too. Turning off and on the plugin after updating them seems to fix the immediate issue, though will occur again if they need another update.