Website Catalog as well as Catalog API not giving results after PageNumber 34

Describe the bug. Describe what is happening when the bug occurs. Describe what you would normally expect to occur.

  • Whenever I try to use the Catalog API and go past PageNumber 34 with ResultsPerPage set to 30, it doesn’t return anything. When I try doing the same thing on the Website Catalog, it also breaks. I would expect the catalog to continue returning results. This seems to be a hard limit, because setting ResultsPerPage to 42 makes it break at PageNumber 25.

How often does the bug happen (Everytime/sometimes/rarely)? What are the steps that reproduce the bug? Please list them in very high detail. Provide simple example places that exhibit the bug and provide description of what you believe should be the behavior.

  • It happens everytime. Below are some Catalog API links for various Categories at page 34 and at page 35, as well as screenshots for the standard Catalog. The screenshots have plugins installed, however I did test this without the plugins and I get the same results.

Some Examples

Page 34:

Page 35:

I’ve searched around the Forum and I can’t seem to find this reported anywhere, so I apologize in advance if someone already posted this.


I can confirm this bug. Ugh :sick: Spammed over to page 34 and then pages 35+ had no results


I realize this should be a separate topic, but I’ve also noticed the catalog api doesn’t return anything related to bundles.


Same happens for animations and featured bundles.


I noticed that as well. I found a work-around by searching for all body parts, which returned them with their AssetIds instead of their BundleIds, but also returned faces and heads.

There is actually a thread for reporting any error to do with the catalog:

Apart from that, I am also experiencing this.

1 Like

That thread is meant for errors with items themselves, like their descriptions or genres. This is under bugs related to the functionality of the catalog.

1 Like

Please use this thread to note:

  • Typos (spelling, grammatical errors, filtered text, etc.) in the text of the item’s name or description.
  • Incorrect genre .
  • In general, issues with a catalog listing .

“Listing” means the asset page itself and the information on it. Not the catalog or the functionality of it.
Also, see below:

1 Like

I’m also experiencing the same issue. This API is really important for our upcoming avatar editor in Adopt Me.


I can confirm this bug as well. I tested the online catalog and a empty page gets returned after page 34 of the search results.

1 Like

This is still happening :frowning:

I have been trying to generate a list of all Roblox accessory ids and noticed that after reaching a certain page API does not return any items. After some testing, I went to the Roblox catalog and attempted to reach that page to check if there are any items. Even though catalog says there are 327 pages with 30 items per page I am unable to reach page 35 or further. In this example, I am only able to access 1049 items out of 9790. I have also tried subcategory “Hair” which has 648 items and I am only able to access around 400 items.

Here is the api URL used to retrieve data:

Gif of catalog not showing any items after page 34 on “All Accessories” category


Same result for me:

An avatar system I’m in the process of making entirely depends on the ability to search through all pages, so a fix for this as soon as possible would be much appreciated.


Thanks for the report! I’ve filed a bug internally with the relevant team. I’ll keep you posted, unless someone from one of the catalog teams does first!


Still no avail or fixes on catalog pages beyond 35, this is especially crucial for searching through, for instance, a specific group’s catalog of clothing. If someone fixes it, I’ll be thankful.

Are they fixing it yet? :thinking:


When using the method GET for the search API on page 35, it returns Error 429, which is basically “too many requests”. Not sure why we get that type of error. I mean, in-game APIs have up to 200-1000 requests per minute.

It’s returning 200 for me on the endpoints the OP linked (although it’s still just returning an empty array as a body), do you mind sharing what links you’re using?

This issue persists on!/Search/get_v1_search_items as well. It just returns a 500 error beyond page 35. Anyone find any workarounds yet?

Using the search API for songs, I’m also not getting any results past page 24. (same empty array as body.)

I’m bumping this for two reasons:

  1. This is causing me issues with an application & plugin I’m trying to build
  2. It was brought up at RDC during Q&A

Regarding #1
It is currently impossible to effectively search the APM music library on Roblox. The only way to find what you want is if you know what exists already. And forget trying to search by duration, genre, album, etc., because you will get a mess of results & still limited to 24 pages.

There are 397,858 songs from APM on Roblox, but the vast majority of them are essentially invisible and impossible to discover. This alone makes the investment into APM pretty pointless, because it’s really difficult to find anything.

If the limit was removed, Roblox devs would be able to build apps/plugins that could easily catalog the library of music and provide users a way to find what they’re looking for. I am specifically trying to do this myself, so that users can search and sort by name, duration, genre, library, and album.

In summary, either Roblox needs to create a better search experience for the APM catalog, or they need to remove the limits so us devs can create something useful.

Regarding #2
A Roblox engineer (I forget who) mentioned that the limit was there to prevent scraping the catalog. However, another engineer (I think @Seranok?) said that it should be allowed. So it seems that this issue is intentional.

If this is an API-strain issue, I wonder if there could be a discussion about implementing API keys for Roblox devs.


Trying to get all hats and I’m getting blocked at 24 pages as well. What was your workaround for this?