Windows 10 App Desktop acting as Mobile

I believe this is the right spot to post this issue:

I don’t know if this game specific however, I believe it is a engine issue.
Playing Roblox with the Windows 10 app downloaded causes it to detect as mobile, showing mobile settings and buttons for example:


https://gyazo.com/f1d7df52c8cce771a3f8482e0a8d5bca


https://gyazo.com/21aeb3ed5626decb167398d6bbeedca9

Also, auto jumping works as usual.

This actually wasn’t happening til 5/8/2020 (when I noticed). This can be replicated by playing the Windows 10 App on desktop, then just playing a game as usual.

My computer doesn’t have touch screen enabled.

Before it never had the options, now it displays all of a sudden.

Also occurs as well on other games:


https://gyazo.com/6bb62d5ee99b007865c2098273f814f2

10 Likes

Is your Windows 10 computer in tablet mode?

3 Likes

No, it just happened a few days ago for no apparent reason. Surprisingly it doesn’t happen with the normal roblox, just happens with the Windows 10 App.

5 Likes

I am not seeing this–I have a Windows 10 machine with a touch screen.
Now if I touch the touchscreen in my game for instance, then it goes into touch mode as it should,
and exits as it should if I use other inputs. (I assume you are talking about the UWP app–The one
that does not start from the web browser.)

If you are seeing this in multiple games, it sounds to me that something on your system is triggering
touch detection (maybe flaky hardware.)

2 Likes

The windows 10 app originally aimed for windows 10 mobile.

1 Like

When I try to play it on my Debian Linux Chromebook, the controls become very weird for some reason. :thinking:

2 Likes

Specific games to look at, anyone?

3 Likes

As far as I know, this doesn’t happen automatically. This can be achieved using software as well, as seen in this video by @UseStarCode_BACON (who uses it to gain unfair advantage in Jailbreak).

Maybe try looking what software you have installed?

1 Like

What I’m not understanding is why this is only occuring on the windows 10 store app for roblox and not the web roblox version. On the web version, it is completely normal, normal desktop controls, normal UI, and etc.

Closest thing I can think of that can cause this issue is my drawing tablet however, disabling that doesn’t do anything either so it’s still occuring as usual. Plus, as said before, it doesn’t happen at all on the normal version of Roblox.

However, its quite odd in what I can do? I don’t believe this is possible on normal mobile, for this game anyways-.
https://gyazo.com/667f9b01ff787fe5d41e41c023e8b6ba

1 Like

Hi, yeah, that’s because the normal browser-desktop version is not touch-enabled–
(On a system with touch, touch actions will be seen as mouse actions.)
But the UWP / Windows Store version is, of course, touch-enabled.

1 Like

I tried uninstalling some programs and checking device manager but it still has the same effect as usual.
Completely uninstalling it and re-installing it doesn’t work either :man_shrugging:

1 Like

I assume the UWP version was mainly for Windows 10 Phone, if they support it

1 Like

The buttons look as on mobile devices.

4 Likes

So I’m 100% positive this is a bug and was never fixed for months as I experienced this that long. Not many people use this version of Roblox but there’s an app for it on the Microsoft store, and this has been going on for many months, almost a year by now, and when you play any game it detects you as playing on a mobile device like a phone or tablet.

This is not on the game’s end, this is on Roblox’s end and I know this guaranteed. I’d just like to know if Roblox will ever be fixing this, it’s been nearly a year and it’s ridiculous.

EDIT

I forgot to add that there’s no sound on the app version either. And you can’t type in certain things because it detects you’re using a touchscreen for typing even though you have a keyboard… Oh and the menu looks like it’s for touch screens and not PC. There’s much more that’s broken with this version but I can’t think of any so far on top of my head. Will add on soon when I think of them

5 Likes

The MS Store / UWP app is already “mobile-ish”, and not great for keyboard chat,
however it works fine for most people in non-touch mode, therefore if this is indeed a Roblox bug, it
would have to do with how Roblox is interacting with your particular hardware / drivers / software–
Therefore anyone who is experiencing this should describe their particular setup / systems in as much
detail as possible, or the problem will likely persist for a long time. Recently there was another bug
reported that appears to be in the category of depending on the particular hardware / drivers / software
as well: Pressing dot on Numpad doesn't work for In-Game Chat
(However this bug is more clear-cut as there is a different behavior between Studio and the UWP app.
Please note again that the Browser / Desktop Roblox app does not have touch support, so using that
same logic doesn’t really work in this particular situation.)
Edit:
These bugs could end up being due to some horrible arcane differences between Desktop and UWP
apps–If this is the case, then they could be very difficult to solve. The little hope is that if these bugs
did not happen in the past on the same systems, then they could be due to Roblox updates, however
they could also be due to Windows updates.

1 Like

This issue is still relevant, unfortunately.

I’m getting reports from some players that they’re unable to play a game that I’m developing because Roblox thinks they’re playing on a Tablet, and the game is locked to computer only. The problem is occurring on BOTH versions of Roblox (Microsoft Store & regular desktop version).

I tested with a player and changed the game to allow Tablet users. He was able to join afterwards, but… we’d really prefer to keep the game to Computer only.

Edit: After more testing it was discovered to be a completely different problem, unrelated to this thread (the game was previously Group Only and the users were in the group but still unable to play for some reason).

2 Likes

After I noticed a bug report post, I decided to do a bit of tweaking around, I’ve found the source to the issue.

You’ll have to disable Windows Pen and Ink services :man_shrugging:
And when I mean by disabling it, I mean by going into the services panel and disabling/stopping it from there.
Would not recommend doing this if you have no idea what you’re doing.

This topic was automatically closed after 41 hours. New replies are no longer allowed.