Windows incorrectly docking in Studio, malformed windows

What is defined as soon? This has been broken for so long now and the whole system should’ve honestly just been reverted.


I’m not sure if this is related to the recent fixes but I’m unable to undock the workspace viewport.

EDIT: This has been addressed on this bug thread.

bro :expressionless:


Sorta related. Happened after I got an error from opening a game I didn’t have access to.

Man, they really need to test these types of things out for a while before actually releasing them to the public :slightly_frowning_face:


Hi @CrazyAlternetive, we have a potential fix for this problem, but it requires resetting of your layout. Please take a look at the link below for instructions on how to reset your layout:

1 Like

Alright, thank you!


this is happening to me too. Know a fix yet?

Thank you for this, it worked for me… for now at least
But i found you do not need to delete the whole “RobloxStudio” folder, just the “RobloxStudio\LayoutSettings”
so i just deleted “Computer\HKEY_CURRENT_USER\SOFTWARE\Roblox\RobloxStudio\LayoutSettings”


Can confirm that this is still happening to me, and it’s been TWO WHOLE MONTHS and it still hasn’t been resolved. Hopefully a fix will come out soon.

Edit: Will try the HKEY method later, and will re-edit if it works or not.

1 Like

This is another docking bug, I’ve refreshed studio MANY times even with task manager, yet no luck.

Sometimes it loads up without the baseplate even rendering and it’s just the default blank color, closing these tabs also causes the docking to glitch out as seen below.

As a developer of a fairly active community game, this is more than frustrating as it’s halting my already limited development time.

Any feedback or potential fix would be appreciated.

God Damn It. Well, i am currently having the same ISSUE, and the only thing that made it 1%+ better was minimizing it and then fullscreening it;

im still having problems on this…

1 Like

I had this issue just now after attempting to use the “test” tab of the ribbon to run client and server. This feature should probably have been culled since we can multiplex the client and server into the same display. Anyway, I wanted to check both looked the same and it came up in historical literature.

It produced two, new, Roblox Studio windows; 1 client, 1 server. One of these had the undocked game preview which led me to this post and was best shown in this image from InfinityIt on Sep 22nd:

InifinityIt posted on Sep 22nd

I had lost control of that “sideshow”, corollary, window in the background. I couldn’t dock it or move it. I had this problem last night too, the daily reboot didn’t solve it.

SubtotalAnt8185 did solve it with:

Try deleting Computer\HKEY_CURRENT_USER\SOFTWARE\Roblox\RobloxStudio from the registry. It worked for me with a problem with the old UI

I was seriously regretting life choices and thinking I screwed my server side code up somehow. I wasted a few hours reviewing the basics of client server as if it was something novel.

1 Like


Yea, tysm dev roblox, useful function.

2022 continues to be the worst year for bugs and updates imo… This needs to be FIXED!

1 Like

this just made it worse for me, this studio bug has got to be one of the worst and even after months they have still done absolutely nothing. not even a comment on the situation, its laughable at how horribly this has been handled

after deleting registry key and re installing roblox studio its fixed

1 Like

Never had this issue before until just now when i opened roblox studio. Not even 2 days ago it was working completely fine for me yet now it is completely broken.

Edit: Should’ve done this before i made the reply but deleting the registry key worked for me. All i did was close studio, delete the registry key and open roblox studio again. This fixed the issue for me.


Three months later and this is still proving to be a MAJOR issue. It was working fine for like the past week and now it keeps happening. The only way to fix this is to literally completely close out of Studio and reboot it. This also can break if you can Studio open on your non-dominant monitor.

Please just fix this already. I’m tired of having to open and close Studio every five minutes…


This has actually gotten worse since yesterday, now anytime I type in a script it pops out every single tab forcing me to restart. This is making development nearly impossible to do now. I do not understand how such a critical issue still cannot be fixed. I don’t know what to do besides twiddle my thumbs and hope for the best. If anyone knows of a fix please let me know.

1 Like