Windows incorrectly docking in Studio, malformed windows

I’ve tried everything. Fresh reinstall of studio.
It happens again and again.

Very weird. By chance, are you using any external program? If not, create a new local account and try running studio.

If that still doesn’t work, try changing these properties to change DPI scaling:

And, if you can manage to do so, try enabling the “DPI aware studio” beta feature.


Hey, that works! Thank you! This bug report will still be up since it does still affect a good number of people.


currently no way for me to fix this

1 Like

Wouldn’t the Test > Local Server feature classify as multiple sessions?

1 Like

ROBLOX, fix this issue please this has been the worst for the past 2 months now, it severely hinders my ability to work.


I’ve been using MaximumADHD’s “Roblox Studio Mod Manager” ever since

Same issue here it happens every time i open a 2nd studio instance.
The 2nd Instance is bound to be messed up with the ui


Can confirm as of 2022-11-07 that this bug is still in play. I only started getting it after the icon update. Not clue if it’s related, but it’s coincidental.


Thank you so much, this worked for me

Bro I have an issue where I the gui are not where they seem they are , you can click nothing and still move an gui object

This is how resizing an gui element goes:

i have the same issue and i cant work cause of this bug. why is it so hard to fix?

Thank you so much. I’ve been using an old studio version using StudioModManager since this update rolled out, specifically the August 30th update, and I wanted to wait it out until a fix came out, but earlier today studio would not let me log in and it said I had to update my studio. I use local servers a ton whenever I test out my scripts, and this broken ui really messed me up, to the point where I couldn’t even work on what I needed to get done, which resulted in the project being delayed by a few weeks at least until i realized mod manager existed. For now, these seem to work, thank you so much for this <3

there’s literally no reason for a bug that is so easy to replicate to exist for over 2 months, I can’t tell if they’re just putting a blind eye to this or they’re just really incompetent to fix this


This bug is still present and is debilitating to development.


same man i dont know why i reinstalled studio and still it didnt work

With all due respect - it is disappointing and frankly unacceptable that this bug has not been fixed or addressed with a rollback option.

It has been several weeks and a substantial number of people are still experiencing these interruptive screen docking glitches.

It is a massive interference to a development workflow and achieving a flow state while building/programming. I sincerely hope this is addressed as soon as possible.



I was so happy that it was working, silly me for being happy. This bug broke and now it takes me EXPONENTIALLY longer to get a testing session open that isnt bugged with the windows popped out, and when I do its always messy. Cant believe how this has been an issue for over two months. If you make an update that breaks the entire software, roll it back and fix it. There was no beta testing whatsoever for this, they just threw a buggy mess at us and gave us no way of downgrading, like Windows 11 but at least Microsoft lets us downgrade. Roblox, you really need to fix this this is ruining many developers experience with your software and delaying many projects

1 Like

This might be helpful