Windows incorrectly docking in Studio, malformed windows

This one is caused by your monitor specifications. We believe that it should be resolved with the new HiDPI beta. Are you enrolled in it? You can find it under File > Beta Features > New Icons / DPI Aware Studio

Can still confirm to this day it still happens.
When I run a testing session with 2 players. It adds 6 windows instead of 3.

3 windows showing the game.
3 windows showing the other panels such as properties, workspace etc.
both being separate from each other which is my problem here, because now I cant run any tests on my game.

Also, this occurs even when you start up a project in the studio normally, you just see the game undocked from its place (in middle of screen) and I have to restart the studio to fix it.

But for the testing session its unfixable, it always happens at least for me.

I don’t want to try to mess with my Roblox Studio Client and edit some codes to make it work properly, Roblox should know better to fix their studio and not make their developers go through all this pain to fix something THEY should be fixing.

This is so disappointing on how long they are taking to fix such a huge bug that is affecting many developers work flow.


This issue is still happening to me. I can’t seem to go a single hour without Studio breaking once and forcing me to close it and re-open it. It will just pop out windows that I am actively working on and forcing them to stay off the main tab, even dragging them back onto Studio window and placing them breaks it and forces me to restart everything. This has been going on for a few weeks now and it needs to get fixed.

(Easy way to recreate this is to drag your workspace off Studio and try putting it back on, you will very quickly find out how annoying this is.)



I have turned that on and still have the issue. It happens sometimes when I start studio. I need to restart multiple times to have it fixed and then the next place I open I have the same issue again.

this has me driving insane. my entire workflow is affected by this particular bug + incorrect docking order of different tabs as well

please somebody fix this, its been happening for quite a while now

You would think two months+ to fix a bug would be long enough but I guess they need longer. It’s not like Studio completely breaks or anything causing you to restart it. Totally just a minor bug…

1 Like

This issue has driven me mad and I’m actually gonna lose it, I can’t work on anything because I can’t even see the workspace.

This is a major issue that needs to be fixed yesterday, this is actually ridiculous that a bug like this is still present. I don’t know what causes it but you should probably not do ui “overhauls” if your just gonna break the ui. I never had issues like this until the new “fancy” studio ui. now I have too many issues to count. including windows not docking, plugins opening by them selves and issues like that. This has made me very frustrated…


Delete registry in regdit worked for me! Thanks

1 Like

The exact same is happening to me, it started happening last week and occurs around 80-90% of the times whenever I open a place

@Epixerty A re-install will fix the issue. We have a fix coming soon.


What is defined as soon? This has been broken for so long now and the whole system should’ve honestly just been reverted.


I’m not sure if this is related to the recent fixes but I’m unable to undock the workspace viewport.

EDIT: This has been addressed on this bug thread.

bro :expressionless:


Sorta related. Happened after I got an error from opening a game I didn’t have access to.

Man, they really need to test these types of things out for a while before actually releasing them to the public :slightly_frowning_face:


Hi @CrazyAlternetive, we have a potential fix for this problem, but it requires resetting of your layout. Please take a look at the link below for instructions on how to reset your layout:

1 Like

Alright, thank you!


this is happening to me too. Know a fix yet?

Thank you for this, it worked for me… for now at least
But i found you do not need to delete the whole “RobloxStudio” folder, just the “RobloxStudio\LayoutSettings”
so i just deleted “Computer\HKEY_CURRENT_USER\SOFTWARE\Roblox\RobloxStudio\LayoutSettings”