Can’t open place file due to ill-formed XML error - entire file overwritten as null bytes

Whenever I open a specific place file, Studio boots as usual however it won’t open the place. I get a specific error message:
Could not open the place "C:/Users/Noble3.0/Desktop/airportCOMPLETE.rbxl" with exception: "SerializerPugi::deserializeImpl ill-formed XML.

The last time I saved this file I used File > Save to File.

The issue occurs every time I try to open it.
I am running Windows 10.
It started happening a few days ago when studio updated to 408.
Place file: airportCOMPLETE.rbxl (161.2 KB)

This is what I see when I open the file in Notepad++:

There is some troubleshooting about the same issue in this thread:

Please fix ASAP as I’ve spent quite a while on this :frowning:


So I worked on this project until last Friday,I get this message,and I still get it. I still get this message even after I re-installed ROBLOX Studio.

This is the message I often get :-

Whats the best way to fix this?

-Thank you.


It’s an existing bug and from what I’m getting the engineers are on it.

1 Like

Hey everyone. I’ve never seen this before and can’t find anything on it. Every time I try to open a certain save file that I made last night, I’m getting this error:

SerializerPugi::deserializeImpl ill-formed XML.

Seems like it didn’t save correctly. Luckily this wasn’t a file I needed too badly but now I’m worried about hitting Ctrl+S (which is already something I do constantly to prepare for crashes). This map was a baseplate and two or three parts, I was simply doing some script testing. I was testing out bullet mechanics on the attached file below. It didn’t crash or anything last night, I just saved and closed it like I usually do. I think it’s also important to mention that I have tested saving and opening new files again today and I haven’t been able to reproduce the problem.

ArcadeStyle1.0.rbxl (55.6 KB)

I am on PC (Windows 10) with the latest Studio version: 0. 395. 0. 324413(64bit). Below are some pictures of noticeably strange behavior.

There is a very strangle clipped off window open for the mobile view mode. Strange because I was not writing code for mobile and I haven’t used that view mode in weeks in any capacity.

Here’s a screenshot of my explorer which is a little depressing…

This is all I get for output.

Sure enough, all the core stuff seems to load in properly.

1 Like

Studio automatically saved my project, but when I tried to open it,this happens.

I need a solution because I will lose my entire project.


This file has been corrupted either during Studio save or by some other software. Do you remember when the file was last saved? Were there any incidents after the save – for example, a reboot or outage when you move/copy the file?

Sorry for your data loss. Hopefully you have a recent backup of the place file.

1 Like

The file was saved on Wednesday/Thursday, Studio duplicated the window for a brief period of time but that’s pretty regular for me. Unfortunately I don’t have a backup, :frowning: .

1 Like

Check what @Dekkonot said

After I posted the topic I did more digging what was the issue and I found that while you’re saving your game to a file and you shut down your pc it occurapts it makes the file content null there might be more reasons why this happened but I only found this one.


A post was merged out for being off-topic.

I desperately need help with this

1 Like

Happening to me too for Ro-Ghoul. Same deal with everyone except for the fact that I didn’t make a save file I just hit publish to roblox and there were no autosaves/recent saves within 2 months somehow.

What worked for me ^ doesn’t work for the developers that don’t publish to roblox ofc.

Since the issue is still relevant (happened to me today), and I found a solution, I decided to show the steps I took to fix this issue since I’m stubborn and refused to accept that I had to start over.

Note: This only works if this file has multiple save points prior to the error!

The Steps

  1. Find the file location, right click on it, and go to the properties option.
  2. Go to the Previous Versions tab and click it.
  3. Find the last save that worked, select it, and click “OK”.
  4. Open the game file, and it should work again!

Just make sure to make backup files like I didn’t to save yourself the stress in the future in case this might not work!


I tried to do what you said but there’s one problem. Seems like i don’t have any Previous Versions. What Am I Supposed to do now?

I’m sorry, but you will most likely have to find a solution for yourself since I didn’t not have that particular issue.

and that happens to me

1 Like

After the outage we’ve seen reports for people for whom Studio cached some assets incorrectly. You can clear out Roblox HTTP cache, see “How To Clear Roblox Cache” at the very end of this post (Windows) How to reset Roblox without resetting your settings


This fixed the issues I was having with the “ill-formed XML” issue. Tyvm!

1 Like

Please file a new bug report if this issue occurs again.