Cannot start test servers on Mac OS

ROBLOX Studio gave out the following error today:
Error while starting server: Failed to start network server, port:53640, error id:6

on my Mac OS Catalina 10.15.5.

I have tried: lsof -i :53640 however nothing it outputted. I’ve reset my computer and reinstalled ROBLOX Studio as well.

Edit for More Info:
I do not crash in Studio. This is a studio-specific bug. This bug happens to all my games in Studio, even when I open an empty baseplate. Everything else runs smoothly.

Edit Update 2:
I found that there are no log files for Roblox. Actually, there isn’t even a Roblox folder for my Mac’s logs under its library!

Edit Update 3:
I used a new computer to get the logs.

Anyone else experiencing this issue?
Anyone know how to resolve this error?

1 Like

I had this same error, it resolved itself when Roblox Studio was updated and I was promoted to allow it though my computer’s firewall.

1 Like

I recommend post this in Studio Bugs and that way you could perhaps get a solution there. Unless it is like what @UltChowsk said where you just need to update studio.

It’s already through my Firewall. Unfortunately, this isn’t the answer.

Thank you for notifying me. I moved it to Studio Bugs.

1 Like

When reinstalling Studio, did you make sure to delete the server program file and rerun it when it was installed? I forgot to mention that, my bad.

Ah, no. I didn’t know there was such a file. Thanks for letting me know. Mind telling me where I could locate it? Unless you mean the server.rbxl file which I did delete for reinstallation.

I am also experiencing this, I got the same error, and 10 seconds later my studio crashed and I lost 3 hours of my work.

Can confirm.

Was having severe Datastore and texture / mesh load failures around the time you posted this.

I do mean the server.rbxl file, did you try running it without Studio open at all after reinstalling Studio?


Thank you. I’ve added the information to my original post.

1 Like

Please include logs as mentioned in How to post a Bug Report

1 Like

I unfortunately do not have any log files or any Roblox folder under logs.

Yes, I have. The error still reoccurs when hitting Start for the local server

Update: I deleted every single ROBLOX file on my computer and installed Studio again but I do not get log files and keep the same error. It seems to be a Mac OS issue that Studio has. Hopefully, it’ll one day be updated to be fixed on Mac. Other than that, I don’t believe there’s a fix for this error.

I recommend using Windows when developing on ROBLOX Studio to avoid this issue on Mac if you have one.

Edit 2:
I used a new computer to get the log files.

I got the logs from a new computer. I’ll message you them privately due to the sensitive information.