Can't upload image for my Developer Product

Just says ‘The file name contains inappropriate text.’ I’ve tried several different names, such as ‘Icon’ or ‘Image’ but it says the same thing. I can’t find anyone else on the Dev Forum with the exact same issue.

Bug happens when I try to upload an image for my Developer Product, under Configure Place.

I only noticed it today, but I haven’t uploaded Developer Products for a while.

To reproduce, go into Configure Place, upload an image file, error should occur. I don’t know if it is only occuring for certain names I’ve been trying, or if it’s just a problem with me doing it specifically.

Edit: Clicking ‘Update’ also does nothing

9 Likes

Pretty sure you need to add some description

2 Likes

Still occurs sadly

1 Like

Why did you black out the name?

1 Like

Just because it didn’t seem relevant to the problem, and it is an identifier of my game.

For context, the name is simply a number followed by the currency name. E.g. 1500 Coins.

1 Like

Change the file name into something like Coins1500 and try changing the actual devproduct name into something like that too

2 Likes

Hello @Adstract I’ve been having your mistake for a long time already, and currently this is not fixed yet.

Maybe I think I’m wrong, but me too when I upload an image he tells me: The file name contains inappropriate text

I Have tried to change the file name in a lot of time but it doesn’t work

Here are some photo about this problem:
1)

  1. Changed the name of the file

Hope that someone fix this problem because I have to create new dev products every time.

6 Likes

This issue is probably caused by Roblox’s “overprotective” security system. Ever tried messaging your friend on Roblox, started the conversation with, "Hey what’s up" and then it turns into hashtags? Even though there was nothing wrong with that statement, Roblox censors out pretty much anything nowadays, so I’d suggest coming up with a specific name with a detailed description. If the issue still persists, try changing your VPN, as this might have a connection to the issue.

5 Likes

Hello! A ticket is already in works for your issue. We will follow up when we have an update for you.

3 Likes

hey @Adstract - the error message is misleading, but I believe it’s actually the name of the Developer Product that’s being filtered. can you try changing the name of the product and see if that works?

4 Likes

Yep, can confirm this works. I have to change name to something that will pass the filter e.g. ‘name’, press save, upload image, save, then change the name back to what I wanted it to be e.g. ‘50 Money’.

3 Likes

Just wanted to add that this solution also worked for me. I had a DevProduct name of “100 Currency” and couldn’t upload an image no matter what I tried naming the file.

Then I changed the product name to literally “Name”, Saved, uploaded the image I had been trying to upload for ages, Saved, then changed the name back to “100 Currency”. Did this successfully for 2 similar DevProducts.

2 Likes


Idk if its just me but this has been loading for a few minutes and it keeps on loading. (cant upload a new image for my dev products) tried multiple places and they yield the same result

update: now trying to upload makes my browser stop working…

8 Likes

Same with me, Did you find a fix for the issue?

No, still not working…
https://gyazo.com/c307f43e2c2c24008b2b1d3c86d4dd27

2 Likes

Yes, im been having the same issue ever since ive started developing. Sometimes it works but, I advise not putting a photo for your Dev Product

Hey there, I think a new issue has just risen here… apparently I am unable to upload images for the developer product that I’ve created, I’ve tried multiple ways to find a solution to this problem, for example by changing the developer product name and the image file name, however, it still proceeds to prevent me from uploading an image. It’s basically taking too long to attach the image to the developer product, but it isn’t giving me an error.

Just like what @royee354 is experiencing.

1 Like

hey y’all - is there an error in the console when you try to upload?

Yes, this error appears upon trying to edit a DevProduct after the image fails to upload.

Screenshot 2022-02-26 223659

It seems that the image does upload, it just doesn’t show (likely because it’s pending moderation)

1 Like

Thanks for the reply. I’ll have one of my engineers take a closer look.

1 Like