How do I remove a private group game from the games page?

What do you want to achieve?
I’d like to remove an unused, private game from my group’s game page.

What is the issue?
I’ve looked through all options and looked at other posts on the devforum, though I cannot find any solutions to it.

What solutions have you thought of so far?
I’ve tried setting the game public and then to private, disabling group games and enabling them again and changing all kinds of game settings.

2 Likes

It should be removed automatically but if its not then just hide group games.

2 Likes

I have other games that should be public, so that sadly isn’t a solution. If it’s meant to normally hide the game, I’ll fill out a bug report.

I also tried it with a different group game (set it to private), and it wasn’t hidden.

It took me for some of my group games up to 24 hours to show but some, they appeared right away.

If this is a concurring issue further then 24 hours, submit a bug report.

1 Like

The game I’m talking about has been private for over than a month. I’ll submit a bug report then c:

Hm, try making it public then private one last time.

1 Like

This seems to a Roblox issue where only developers, who have access to the game can play, lots of people have just turned it private and public a few times and it worked for them, Roblox will most probably make another option for developers to play private games. I went into editing the game and changing settings within the settings on Roblox Studio and it seemed to fix itself.

1 Like

Tried all the solutions given here - nothing worked. The game still shows on the group page.

Well if you don’t have any other games that you want to show, you could just turn this off.

1 Like

I sadly have one different game that I’d like to keep.

This has been an issue for at least a year now, I’m still hoping for a fix.
Here are some of the examples.

1 Like

Has been an issue for a long time and still is… This is a really annoying issue and I’ve experienced it for a while.
This game is supposed to be private, I’ve closed it and no longer want anyone to see it on the group page like it used to do, but no amount of turning the game from public to private or waiting in between doing that fixes it.

1 Like

This is happening for me too. I tried to mark it as public then private but that did nothing. I also tried to mess around in the game settings but that did nothing too.

1 Like

Same here. It is pretty annoying. Any workarounds?

1 Like

Please file a bug report or support an existing one. Engineers will not see it if you post here.

1 Like

If I read your post correctly, have you tried archiving the game in studio?

2 Likes

I don’t think I have, I’ll check later today. Thanks!

1 Like

I am currently experiencing the same problem!