MeshPart Collision problems

When importing a mesh part to be used as a system of accessible pipes in my game I’m having problems with unexpected collisions with my mesh


when trying to move into a pipe which is clearly open and also on the sides of the mesh which aren’t enclosed like the pipe.
image
This is what happens when the collision fidelity is set to default, in hull and box mode the collision is treated as one large block. Does anyone have any solution to overcome this problem? Ideally this would be a slide.

2 Likes

Roblox’s collision system doesn’t like concave shapes, as the automatic collisions are based on convex.

2 Likes

To better understand how Roblox handles collisions with meshparts and unions, turn on ShowDecompositionGeometry in file -> Settings -> Physics. Generally you will not get good collision fidelity in large or highly detailed shapes.

3 Likes

Edit:
To add onto that, IIRC, the collision detail is measured as a percentage of a CSG/Meshpart’s complexity, meaning that the more complex a shape is, the less “focus” is applied to collisions and is instead spread across the whole shape.
So even splitting a mesh at a random spot (not necessarly at a concave area) for smaller, less complex chunks will allow ACD to focus on fewer triangles and create better collisions.

4 Likes

–bump–
there really should be a “exact” mode
it should use the same collision as the rendering
it would be laggy but a custom one would be 100x more laggy

2 Likes

You should support (like and reply with new use cases) the feature request in the feature request category then, engineers won’t be going through support threads for requests when we have a dedicated category.

2 Likes