Roblox Player isn't rendering anything

After joining a game or directly opening the app nothing renders. This includes the game itself and all of the UI. Audio works and I have the custom cursor. To close the app, you have to click the close button twice.

I have tried reinstalling Roblox, restarting the pc, and updating the gpu drivers.

This is occurring as of 4/22/2023.

Issue is basically identical to these reports from last year:

Windows 11
Intel Core i5-11400H
NVIDIA GeForce GTX 1650 Laptop GPU
8 GB Ram

A private message is associated with this bug report


Thanks for the report! We’ll follow up when we have an update for you.


@cornprices Is this issue still happening?

Yes it is still happening. Tried reinstalling again as well.

  • Update: it seems to have gotten worse since the last update on 27/04/2023

Seems to be resolved now (for me).

not for me, i’ve even tried installing the 32-bit client

a staff member has said (in here) that its because of badly written drivers, or hyperion thinking that your using a VM

i don’t know which of those it is.

Hello koata,

Please note that the link to one of my posts relates to a different issue. This might not apply to the issues in this thread.

This has not been happening to me precisely because I play on mobile and my jobs are only done once a day.

This also occurs for me, but it was resolved 2 days ago.

Now it occurs again, shortly after another update.

Happening again as of a couple days ago.

This is happening to me as well.

I can’t play Roblox on my Windows computer now.

Yes, it IS 64-bit.

1 Like

Have you tried this solution? It worked for me although it still crashed or closed itself when I joined two or three games but then it worked again

This is still happening as of 6/1/2023.

Unfortunately increasing GDI handles to 64000 (from 10000) and restarting made no difference. Still experiencing the issue.

Try using the microsoft store version of roblox
I have a similar issue when opening roblox from browser, but the microsoft store version works. Oddly enough roblox studio works fine, so there’s that.

Windows 10
Intel i7-1255U
NVIDIA GeForce MX550
(note this is a laptop as well)

I’ve had to use that app for quite a while now, and it nowhere reaches the quality of the Roblox Player.

Along with this isn’t a solution, it’s barely a band-aid

The issue emerged after migration to 64-bit version, we are still working on identifying the root cause. Is it still present , and if yes, do you use recent 64-bit versions of video drivers?

The issue is resolved for me, again.