Ropes breaking for some reason

I have 2 parts that spin around a center part, held by a rope constraint, The center part is anchored and moves with TweenService, when I run the game, The part spins like normal, but when I play it, one of the parts just stops.
This is how the parts move when i run the game:

This is how the parts move when i play the game:
I have no Idea why this could happen
Small edit: It seems the only part that moves properly is the center one

Sounds like a physics sleeping issue as it is involved with constraint physics try following the below steps to debug this kind of problem:

1 Like

This is due to an active bug where replication fails on a part constrained to an anchored part.
(report here: Physics parts attached to anchored part by ropes during tween not updating until tween has finished - #6 by The_Sink)

You can work around this for now by using TweenService/ setting CFrames on the rope’s attachment WorldPosition, rather than the anchored part.


The anchored part does move, its the unanchored parts that dont, they snap to the correct position when the tween stops, and they even start spinning like they should.

Yes, move the attachment connected to the anchored part instead.