Setting the volume in Roblox's client mutes sound previewing in studio!

Setting the volume in Roblox’s client mutes sound previewing in studio!

  1. Set volume in settings menu in Roblox to 0
  2. Try to preview a sound. You’ll hear nothing.
  3. Expected result: Preview works, volume on client does not affect this.
  4. Actual result: No audio plays, and I’m not sure why.

Current work around:

image

As a Roblox developer, fixing this would be good, because now I could consistently preview audio.

60 Likes

I just had this problem and it was driving me crazy! I couldn’t figure out why my audio wasn’t playing at all (in a baseplate project no less). Thanks for pointing this bug out!

5 Likes

This has been a very long standing bug, and I’m not sure why this hasn’t been fixed yet. It’s very annoying and needs to be fixed.

1 Like

So THATS why that was happening! Thanks Quenty!

1 Like

I can confirm this happening.
I’ve been having this bug basically ever since I started developing, but I always thought it was an intentional feature.

1 Like

I can confirm this issue.

I’ve been experiencing this for a while now, this happens with both sound, graphics and pretty much all game settings.

2 Likes

When I met this error for the first time, I was very scared. I thought that the speakers were faulty or the sound driver * flew off *. This error has existed for a very long time, although everyone forgot about it …

1 Like

I’m guessing it’s because, as far as I know, no one has submitted it! That’s why it is important to file bugs!

1 Like

Looks like staff is already aware:

2 Likes

Oh my gosh, I’m SO bad at finding these threads. I’m so sorry!

3 Likes

Many thanks for this! This bug was driving me crazy

1 Like

Thanks so much for pointing this out, I’ve been experiencing this and I had no idea why.

please fix this roblox, this is very annoying

Yeah i know i was so confused about it… i tried many commands but it didn’t work

Just got this bug, it’s very annoying. Thanks for helping

I can confirm that this is still a problem.

Preview actually broke for me, I had to run my game and run :Play() on sounds.

Bug confirmed.
I have been pulling my hair out trying to figure out why my sound wasn’t working, i hope roblox fixes this asap.

1 Like

As of 3/16/2022 @ 7:00 EST this problem persists. Its been almost 2 years and this still happens

3 Likes

This is still broken and I can’t figure out how to get audio working in Studio again. There is no logical reason why Studio should mute itself like this.

2 Likes