Skinned Animations Rendering Issue

EDIT: I’ve narrowed this down to the use of the new RigidConstraint. Removing all RigidConstraints from the humanoid model solves the problem for me.

Reproduction Steps

  1. Have multiple skinned rigs within your camera’s view
  2. Play any animation on them
  3. Move the entire rig back and forth

edit: rig must have RigidConstraint being used in it.

Repro file has been added privately.

Expected Behavior
I expect the animation to play without degraded performance, and especially stay rigidly aligned to the HumanoidRootPart.

Actual Behavior
Degraded rendering on the rigs that are further away (lower perceived FPS on the animations, even though actual FPS is high) and delay when moving the rig’s root part - the skinned mesh will lag behind the root part significantly. ← user submitted video showing how bad it gets.

Issue Area: Engine
Issue Type: Display
Impact: High
Frequency: Constantly
A private message is associated with this bug report


It’s an optimization not a bug. But the fact that it’s this obvious is pretty concerning.


It’s unexpected behaviour - we need to be able to have more than a few animated rigs in frame at a time. If its intentional, then it’s over optimized to the point that it’s a problem.


Have you perhaps enabled this?

Yes, it does not change anything.

Thanks for the report, we’re taking a look.


Any update on this? The repro file still shows the bug.

Sorry for the delay, we’re investigating.


We’ve found the root cause of the issue; it’s not specific to RigidConstraint - rather, it’s a more general limitation of the humanoid rendering system. Try setting the C0 of a weld every frame instead of using a RigidConstraint and you’ll see the same problem.

We’re looking to solve this in a general way.


How long until we can see a solution implemented for this?
RigidConstraints is a great and simple feature, made mostly useless because any more than a couple of them on screen causing rendering issues.


I am having a similar skinned mesh part problem. How long until a resolution

Lagging when changing transparency

We understand the problem and have a fix in progress, but we don’t have an exact eta. We’ll get it out as soon as we can, thanks for your patience.


If possible do inform us here when the fix is released and confirmed, cause there’s so much potential that this bug is currently preventing such as precise skinned mesh hitboxes, currently it’s possible to do it but it would be a lot more efficient to simply use rigidconstraints cause as echoed by some above, having more than a couple rigidconstraints in the game will cause very significant animation throttling even when that feature is disabled.

1 Like

We have enabled a fix for this today, please let us know if the issues are not resolved.


i din’t touch my game for around 2 weeks and come back to this i don’t know if it has to do anything with this new update(animation throtteling) but i think it does since if i remove the animation controller animating a subtle swing to the cape bonemesh (single block meshpart with a couple bones) it works

if the animation is playing u get this derpy thing which i din’t have 2 weeks ago there it worked perfectly before withoud the derping

It’s hard to say if it’s related or not, can you post an rbxl file?

1 Like

its seems to magicly be fixed again as well, don’t know thx, i rather not publish the hole game im working for a year on now as a public roblox file and im a bit too busy to make it seperate version with just the cape as i think it needs to be attached to a moving body to be atleast simular situation

but it seems to be fixed so no need
sorry to bother

1 Like

I’m still having an issue with my game, I even have both animation and interpolation throttling turned off.

I haven’t been here for a long time and tested it 2 days ago, yes it’s very nice, there seems to be no bugs.
thanks roblox team :slight_smile: I will continue where I left off

Closing this since the original poster has a solution. Please file a new topic if the issue still occurs for you with more details!