Studio Viewport Undocking Bug


The Roblox Studio Viewport has been actively disappearing and undocking itself. The behavior itself is relatively consistent on my part. This is a massive issue for me as I am not able to develop the content I am working on, and with a deadline, it is very worrying for me. This issue has just started occurring after the update that released today (timestamp provided in the footer).

Reproduction Steps

  1. Open Studio, any place.
  2. The viewport will not be shown, a grey or black screen will appear.
  3. If the viewport is showing, playtest, open a script, and return to the main game viewport, step #2 should occur.
  4. If you un-maximize Roblox, the actual viewport may be in the top-left corner, this isn’t always the case, though it may happen.

Expected Behavior
To not have the viewport pop-out or vanish completely.

Actual Behavior
The viewport pops out or vanishes, disabling capabilities to play-test or view in-game content.

Restarting studio a multitude of times has a random chance of not breaking the viewport. However, this does workaround breaks after play-testing and editing scripts.

Issue Area: Studio
Issue Type: Display
Impact: High
Frequency: Often
Date First Experienced: 2023-01-11 14:00:00 (-05:00)


We’ve filed a ticket to our internal database, and we’ll follow up when we have an update.

Thanks for the report!


So many other reports of docking issues:
-Studio windows on 2nd screen saving in different position off edge of screen
-I can no longer undock the viewport in Studio
-Windows incorrectly docking in Studio, malformed windows
-Studio environment/script editor viewport stuck outside of Studio client - #9 by 7z99
-"Modern Studio" (new docking behavior) has various issues - #17 by BostonWhaIer
-Studio windows on 2nd screen saving in different position off edge of screen
-Asset manager and toolbox renders outside of docked window contraints


You should see a dialog come up which looks like this
If you click restart, it will reset your layout and resolve the issue for you
Please let us know if this dialog does not come up


I indeed just got this
pop up right after I ended testing

and a work around I manage to use is opening the game from the website instead of opening a new studio window and loading from there

1 Like

I am still having the issue and i am not seeing that dialog. I can recall seeing it before but that did not fix the issue.


Thanks! Can you try updating Roblox Studio and restarting? On version 560, this should now be resolved. Please let me know if this is not the case.


I too am having a similar issue, as the dialog isn’t showing for me, and I’m on version 560.

Its not coming up for me

Seems to still be happening to me.

@kinglalu @EmmettFrowns @EasternBloxxer If it still doesn’t show up for you then open the quick open menu (CTRL + Alt + P) and type in “Reset View”, then press enter.

Alternatively, if that still doesn’t solve the issue (or quick open doesn’t show up for whatever reason) then open the registry editor and go to HKEY_CURRENT_USER\SOFTWARE\Roblox\RobloxStudio and delete the LayoutSettings folder (or key)



Thanks. The first one worked for me.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.