Unable to distribute UGC limiteds in game

Unable to distribute UGC limiteds

In-game with prompt purchase using MarketPlaceService:PromptPurchase() fails.


-- ID will be UGC Limited id

Running this code will result in following error, despite having copies left and enough Robux to purchase it:
Tested on iOS and Windows, both produce the same error.

Expected behavior

Usually when purchasing assets it does not produce an error on purchase, and it should be purchasable in-game like other assets.


I am unable to reproduce this issue.

Tested Asset:

Can I see your script? Perhaps that is the issue.

Try it in-game not in studio test purchase

Still unable to reproduce the issue.

The error only occurs after you click buy, the item displays before like in your picture.

1 Like

I don’t have enough robux to test that, but I’ll take your word for it. You should probably mention that in the OP :slightly_smiling_face:

It’s self explanatory when the error says “failed to purchase” which means the purchase request was initiated :+1:

1 Like


That’s awkward. :joy:

Maybe try it with an item that isn’t sold out? I believe this is the default error that displays when attempting to purchase an item that isn’t available. @codedcosmetics

1 Like

That screenshot is from the item had stock. I’ve tried with several other items as well.

1 Like

At the time the item had stock, I’ve also tried this at the time with the same UGC and I had received the same message


This is still a current issue, and it’s becoming more and more difficult now that the catalog is having more and more UGC Limiteds created.

In the DevForum post about the release of UGC Limiteds it states:

How are developers supposed to monetize off of this opportunity if we are unable to sell items from in-game?

No matter what the ID is, I cannot sell limited items from in-experience. Please fix this ASAP as it’s becoming a huge inconvenience for players, and us developers are losing a large opportunity for revenue.


i tried to make a game which would prompt me the limiteds when they came out then i had this issue too really annoying

please sort this issue roblox its been proving to be a massive inconvenience to me since the day ugc limiteds were released.

1 Like

Was this an issue with roblox made limitef u’s

Experiencing the same issue.

UGC limiteds cannot seem to be purchased in an experience (using the marketplace service).

Could you edit your post to follow these guidelines, please? How to post a Bug Report

1 Like

The original post has been updated.

Hey everyone, thanks for flagging! We got a little ahead of ourselves in the documentation for this feature but this is (temporarily) intended. In the next few weeks we plan to release an update that will enable in-experience purchasing and the seller share for UGC Limited items, so stay tuned.


Hey all! To follow up, in-experience purchasing is now enabled for UGC Limited Items. Thanks everyone for your patience and for flagging the issue.