Studio immediately crashes 100% of the time when attempting to edit a game

The issue

When attempting to edit any game or open a local place file Roblox studio immediately crashes and shows the dialog below:

Crash Dialog

This crash happens every time I attempt to open studio, whether it be by clicking the edit button on a game or by opening a local place file. Studio never actually opens and always shows the crash dialog above. This crash only happens with studio because I am able to play games on Roblox perfectly fine.

I don’t know the exact date or time this crash started happening but I have been experiencing it for a few days now. This crash may have been caused by one of the recent release notes(447, 446) because I started experiencing it a day or so after these were released.

I have tried reinstalling studio multiple times, restarted my computer multiple times and tried updating my computer and this issue doesn’t go away.

Repro steps

These are the steps that I take to causes this crash to happen:

  • Go to the create page on the Roblox website
  • Click edit on any game
  • Then studio will immediately crash

or

  • Go to any local place file
  • Double click it
  • Then studio will immediately crash

System info

  • CPU: Intel® Core™ i5-6200U CPU @ 2.30GHz
  • Memory: 4.0 GB DDR3
  • GPU: Intel® HD Graphics 520
  • Windows 10

Log/Dump files

https://devforum.roblox.com/t/studio-crash-log-files/769988

13 Likes

I’m having a similar problem while trying to play my game in Studio. And in an aleatory way: Roblox Studio Crash - Unexpected error.
This started to happen after the last two Studio updates.
It smells like memory leaks.

6 Likes

Studio still keeps crashing every time I try to launch it. This crash is massively impacting my workflow because I have been unable to access studio for 5+ days now because of this crash. Last week studio worked perfectly fine. Every time I try to launch studio it immediately crashes 100% of the time and shows a dialog like this:

Since I made this topic I have tried a few things to see if I can fix this crash my end but nothing seems to have fixed it:

  • I have tried doing a deep virus scan and nothing came up.
  • Removed everything associated with Roblox and tried reinstalling it.
  • Updated a few of my drivers.
  • Tried right clicking studio and then clicking run as administrator.

I don’t know if something my end is interfering with studio or there is a problem with studio. Every program I have installed, including Roblox player, works perfectly fine exept Roblox studio which crashes 100% time I try to launch it.

Out of curiosity I installed the Avatar Evolution Build of studio and this version works perfectly fine. However I can’t use this build of studio because it is outdated any may be unstable. This means something must be interfering with the current version of studio causing it to crash.

Note: I am using the latest version of windows 10.

Edit: I haven’t downloaded anything recently or modified studio.

4 Likes

Thanks for the reports! DM’d both of you

7 Likes

Thanks for the response. I’ve responded to your DM.

2 Likes

As I reported here, I had to create a new Windows 10 installation (on VMware) and for now, it’s not crashing.
Have you tried a new/fresh Windows installation?

4 Likes

Not yet. I will look into installing a new windows 10 installation though. For the time being I think I will wait for Roblox to investigate just in case it is an issue their end.

1 Like

Updating this with solution:

Looks like this was a rendering issue that was fixed by switching the Graphics Mode to OpenGL. Can access the Graphics Mode setting in Studio Settings under Rendering.

12 Likes

Hey, I’ve recently been suffering from this too, roblox studio instantly crashes whenever I try to open anything at all in it, and I dont know why, and I would try the render mode but since I can’t open studio I can’t change the rendering. I’ve also tried reinstalling studio, deleting all studio versions and its folders, reinstalling them, restarting my computer and nothing. Right now Studio is being completely unusable by me.

1 Like

You can try these steps. If it does not work, read the rest of the thread… there are some additional tips

2 Likes

It worked, thank you very much.

3 Likes

I now have this issue now. Out of nowhere when I tried opening a place it crashed. I’ve tried changing the graphics mode that had no effect. My graphics are also up to date.

UPDATE: Seems like disabling all plugins fixed the problem. Could have been that some of them needed to be updated but these plugins haven’t caused me any trouble in the past so I don’t see why they would now.

1 Like

My friend @7yanz experiences this as well on a macbook pro 16.

7 Likes