Studio on mac tremendously laggy

Hello, this is my first Topic. I’m here to report a bug usually happening on mac that I’ve had since December. I’ve read several other posts about this topic and they all have similar issues to mine. Doing things such as opening the Toolbox takes a length of several seconds to a few minutes. And typing scripts is a nightmare - it literally takes around 10 seconds to type one letter, and while that’s happening, Studio freezes and I have to wait until the typing is finished before it unfreezes.

Right now I have a 2017 Macbook Air Catalina as the screenshot below shows
Screen Shot 2020-04-28 at 12.37.19 PM

I also have plenty of free storage on my mac and Studio only runs about 25% of my CPU.
Screen Shot 2020-04-28 at 12.46.25 PM

I have followed these instructions for a Microprofiler dump file and here it is
microprofile-20200526-081608.html (866.3 KB)

If you are also interested, I have found a video on YouTube that has the same problem as me:
https://www.youtube.com/watch?v=SbsVJZm6898

GENERAL ISSUES
Opening Studio already takes a few minutes to load and to edit a game it takes an alike length. When Studio is open, it slows down any other applications like Google and Discord. Also, I don’t know if this is an update or a bug but when I right-click on an object in Explorer, it normally shows the menu with the “Insert Object” option. When you hover your mouse over that option it should show a separate menu on the left showing the things you can insert. But that no longer appears for me. I have to click the “Insert Object” button and it will show the old way of inserting objects:
playlist

UI ISSUES
Creating parts, clicking objects in the Explorer, moving them around, renaming them is completely fine. Using the move, rescale, and rotate tools are also fine. But when opening UI such as Terrain or the Toolbox it will usually take around 30 seconds or longer before it opens and is able to be used. While the UIs are opening, Studio freezes and I am not able to do anything unless the process is finished. The worst UI issue is that some UI such as Properties and Explorer gets randomly detached when I click on something in the Explorer. When the Properties tab gets detached from its place. It takes an extremely long time to put it back in place, usually a few hours. This is because it keeps getting attached to the wrong place instead of the default location like when you download Studio (Where the Properties tab is under the Explorer tab). Re-installing studio doesn’t help with this problem. This has happened to me around 20 times and by the time of typing this report I’m still trying to re-dock it to its original place.

SCRIPTING ISSUES
As mentioned in my summary, “it literally takes around 10 seconds to type one letter, and while that’s happening, Studio freezes and I have to wait until the typing is finished before it unfreezes.” Now I just use another text editor like Visual Studio Code to copy-paste my scripts into Studio.

TESTING ISSUES
Playing a game or stopping it is the second-worst thing to happen other than scripting lag being the first. It takes around 5 minutes to play or stop a game. And currently, I am in the development of an upcoming murder mystery-like game. But to start a game, the server requires 3 players. You already know where this is going - I have to test with 3 players. This usually takes a duration of 10 minutes for all 4 Studio applications to load and be usable. However, switching from different player screens takes another 2 minutes to load, and this annoys me a lot.

SOLUTIONS I’VE TRIED
I’ve read a lot of other posts about this and here are all the solutions I’ve found and tried:

  • Re-Installing Studio
  • Changing Display Profiles of my mac
  • Setting my Studio Settings to it’s minimum
  • Restarting Mac
  • Changing Display Scale
  • Unparenting Script Editor
  • Clearing Cache (Partly effective)

Having these issues right now is a struggle because I currently maintain a Roblox coding channel on YouTube and it holds me back from uploading regularly. I would like to hear back from the staff team about this because I need to get rid of it as soon as possible.

12 Likes

I haven’t experienced any problems with Roblox Studio for macOS, probably because I’m on a mid-2015 MacBook Pro.

You sure there aren’t any CPU throttling on the laptop or running very hot?

1 Like

Hey,

I’m 99% sure I know what the problem is and I hope I can help you because there is a solution to it. SO basically I’ve been developing on my MacBook for years and it worked fine until roblox studio had multiple updates. Through time it became a “nightmare” I couldn’t move a block without having my laptop freeze for 5-10 seconds. I’ve then downloaded a RAM checking app (not RAM thats impossible it’s a checking App) and I noticed that roblox studio took like 70% of my RAM once I opened it. (That’s what the App said) I then started closing all other Apps such as Spotify, Google Chrome, Discord (And everything else). I only had roblox studio open and it worked much better. One day which was about a year ago another update came and I wasn’t able to open roblox studio on it anymore. My MacBook was from 2014 or 2015 I don’t really remember. I now changed onto a normal windows PC and it’s killing it. I’ve told myself that I’ll never ever again buy a MacBook or iMac.
Anyways here the solution again: Close all other Tabs Discord, Spotifly etc and the lag should get reduced. It should work!

I hope this will help you! :slight_smile:

  • Cheerful
2 Likes

When the lag comes, the CPU rises to around 60% then drops back down after. The laptop is heating a bit over to the left corner where the headphone socket is

1 Like

This is not the problem, I know since ive been experiencing it too for about a fortnight.

Im currently using a very powerful and modern Mac with a good amount of free storage.

Now I can even prove that these issues are on roblox’s end, since as an experiment when the script editor is in the main window, it uses up 100% of my Mac’s CPU. when it is not in the main window (even if it is the same size as when it was in the main window) it runs smoothly.

Theses Mac issues completely put Mac user’s development experience on roblox to a halt and should be paid more attention.


@DevHumor – tagging you in since this also kinda answers your post in the fact its nothing to do with the power of the Mac.

4 Likes

It could be that you have an old graphics card, see the minimum / recommended requirements. Or optimize your computer. This has been my answer, I hope you do well. Greetings, rodi_xo

2 Likes

I’m having the same issue. I have a 6-core 2.9ghz 32GB of ram.

Today, the app became completely unresponsive when opening certain scripts. Watching in Activity Monitor, the app continuously increased in Memory until I killed it. At the time I killed the app, it was consuming a whopping 40GB of RAM, which included almost 10GB of swap!

  • At the time of the test, I had a fresh install, zero plugins, zero beta features
  • Script editing is extremely slow even in a completely blank world with a single script
  • (UNLESS) I drag the script editor out of the main window, in which case the performance is fine

UPDATE: I was able to find an error in my script that was the cause of the 40GB freeze issue, but there is still lag when typing. I wrestled with how to view/edit a file that was locking the whole app, and finally realized I could print out the scripts contents using the Command Bar, eg print(game.ServerScriptService.MyScript.Source), then paste that source into a script window that I’d already detached from the main window. Once I fixed the error, I updated the old script the same way

1 Like

OMG I thought I was the only one. I have the early 2015 MacBook Air and it works perfectly on studio… except scripting. It takes at LEAST 10 seconds to type 2 letters. Don’t get me started on trying to test the game in studio. I’m glad I’m not the only one. I use my notes app to type out little sections of a script at a time or I open up a blank glitch tab and open a .LUA file and copy and paste. These methods are very very inefficient.

3 Likes

I also have a PC that’s about 6 years older than my Mac and scripting has no issues on there.

1 Like

Have you tried dragging the script window away from the main window? That works for me, when I can actually get the script to load without freezing

1 Like

You’re great!!! It worked for me swell. This still doesn’t fix my performance issues on Roblox’s end.

1 Like

As I upgraded Roblox Studio to version 434 on my mid 2015 MacBook Pro (with intel graphics only), it might have fallen victim to this issue. In my specific case, Studio runs consume 40% CPU and 1 GB RAM. Typing scripts started to become noticeably slow while CPU fans are rampant.

I am not quite sure if this is expected behavior or fits in to what happened to other developer’s Macs.

1 Like

I’m also experiencing this a lot lately. Specifically within the script editor.

2 Likes

I’m having the same problems as of today, restarting does nothing, and I redownloaded studio.

2 Likes

This has been a real issue, even on the 2019 iMac.

2 Likes

This is still happening…
Roblox has a horrible track record taking months to fix Mac issues before they pop up again - don’t rely on them to fix this in a timely or permanent fashion.

If you’re a programmer, use VSCode + Rojo + Github. I publish to game and test it with a live play session rather than forcing myself to use studio. If I need a multiple person playtest, I just connect on an alt with my phone

Here are previous threads with roughly the same bug. There are more than just these...

Mac Studio is incredibly laggy
Text delayed when typed into script (macOS Sierra)
Super laggy script editor on Mac - fixed
Typing in the script editor is extremely slow in macOS High Sierra/Mojave/Catalina

4 Likes

The previous thread mentioned with color profile fixed the problem for me. Thank you!

1 Like

In my experience all of Roblox on Mac is horrid compared to windows. There’s something just not “right” about the graphics, It uses double the RAM a windows machine uses, and overall feels like a direct port from windows, with no support for the MacOS toolbar or touchbar.

3 Likes

My friend @GooglyBlox_Improved experienced the same thing.
According to him , the only fix was a new laptop , which wasn’t a mac.

1 Like

You should blur the serial number for safety.

2 Likes