Typing in the script editor is extremely slow in macOS

I’ve had my Mac since the summer of 2014 and never had any major issues with it, until now. About a month ago, I started experiencing a glitch where in script editor, there would be a massive delay (upwards of five seconds) between typing and it showing up in the script editor. This happens in every game I try to edit, and it happens every time. Quite frankly, it would take well over a couple minutes to write a simple print statement due to this lag/delay.

I tried everything, like reinstalling and uninstalling Roblox and Roblox Studio, switching the display settings, and even tried deleting a bunch of files on my computer. I updated from Sierra to Mojave thinking maybe it would fix it (I experienced a minor Roblox glitch that was solved when I upgraded to the newest macOS a while back), but that only made the problem worse, as now I would experience delays/lag when I tried moving objects around in Workspace or trying to edit their properties.

The glitch has made it extremely difficult to develop. Right now I use third party program editors (W3Schools, for example) to edit scripts, or I use an Windows laptop I have, but it is annoying to have to switch back and fourth between the two, especially since I’m far more used to Mac than Windows. Another solution I used was dragging the script editor out so it would be it’s own window.

Here are my Mac’s stats:


I’ve had this issue but I found out it was ROBLOX+ I removed it and studio hasn’t lagged since. I recently added it back and shocker it lagged but only after a while I used it. If that doesn’t work then try reinstalling chrome (assuming you have chrome) or use another browser. If that still doesn’t help I honestly don’t know maybe try contacting apple or just wait for someone else to reply.


I don’t use chrome, I use firefox. I tried uninstalling ROBLOX+ regardless, and nothing changed.

I’ve considered it to be an Apple issue but I’m starting to doubt it. I can still run games on ROBLOX rather well, and can still do most things on my Mac. I’ve heard of this issue being a problem in the past for developers (but didn’t affect me at the time) and the only solution was a patch released by ROBLOX.


Ah, ok! Glad to hear it was fixed.

I still have the studio issue, I cannot edit scripts nor move things around with it lagging severely.


Oh sorry, I thought your issue was resolved because you said:

Its possible that it could be studio but for me on my macbook it works just fine.

1 Like

All good, my bad for making it seem like it was fixed. And yeah, Macs have always been weird. There were a few big issues I remember hearing about in the last couple years that a lot of developers had but I never experienced, and then this issue only a few people have been experiencing it.

Hm, very odd. Maybe just wait until someone else or the staff replies because I am stumped.

1 Like

Has anyone else had this issue? There was a Studio update today, and I thought it would assist with the issue, but nothing’s changed.


This is has been an issue for a while now, there are multiple devforum posts about it. If I remember right it has to do with the DPI of the display on the newer 5K Mac models (like mine). I’ve noticed however that it gets significantly worse if you have multiple Studios and/or Roblox Player open at the same time.

Haven’t seen too many devforum posts recently about it, seems like the bulk of the people experiencing it experienced it around a year or so ago. My Mac is pretty old (it’s before they days where they started making them thinner and thinner, and removing things like the USB ports - or was that just a rumor?), and it was fine up until about a month or so ago. Recent updates to the OS and Studio itself have just made it worse - right now, I’m in one Studio window, with an open baseplate, and I can’t switch my POV without it lagging every 2 seconds for 3 seconds.


Another update: One of my Twitter followers said that a complete factory reset of his/her Mac, combined with removing every ROBLOX plugin on Studio, and then installing another one that toggled the ROBLOX UI editor on/off, fixed the issue.

It’s a pretty simple solution, but I’m not up for the factory reset part. I’ve had my Mac for over four years and I have a lot of stuff on here I wouldn’t want to lose (backing it up on a USB, if big enough, would be a pain)

And generally, I don’t know if this fix would work for me/others. There have been other solutions mentioned here on the Dev Forum that were far less invasive that I’ve tried, and they didn’t change anything for me.

That Twitter follower did mention that the current/new ROBLOX UI editor on Studio was part of the problem.

1 Like

Probably my last update on this thread - a factory reset has seemed to have fixed the entire issue.

As stated before, didn’t want this to be the solution, since it involved the erasing of all my files gathered through the years - I believe I’ve backed up most of the memories on a flash drive, but I’m sure there were others that fell through the cracks.

Regardless, the issues I’ve mentioned before are no longer, but the biggest question I have is if this issue will return or not, as I really don’t want to have to factory reset my Mac every time this happens.


Would you be willing to post here if this issue occurs again? I have the same problem and I can no longer use Roblox studio. I’m debating re-imaging but I imagine the problem will just come back and I’m not willing to regularly re-image my computer.


Of course. And so far, it’s been a week or two since I factory reset and everything’s been good…

knock on wood


I am having this issue on my Windows 10 computer. It just started about 3 days ago. Whenever I open a script I get this warning in the output.

Edit: After restoring windows, my Roblox studio is back to working properly.


My Mac has been experiencing increasingly an increasingly laggy script editor for the past month or so. I’m going to run a full factory reset like @CoolJohnnyboy recommended. I’ve changed my display profile and deleted and re installed studio multiple times. Editing the scripts in a separate window seemed to fix the script editing problem but overall studio is just one big lag party. I’ll update this after the computer is reset

Update: Studio is completely fixed. Took a bit for the factory reset but it’s totally worth it.


I’m also experiencing this issue, however I don’t really want to factory reset my computer… There’s four years of work on this computer (not only mine but my family members’ as well). This started for me yesterday and I don’t know what I did. I’m running a 2014 Mac Mini on macOS Mojave. Anyone else found a way to fix this without a factory reset?

Edit: As @Spraden said, editing scripts on a new window seems to get rid of the script lag, but for some reason when it’s a tab in Studio, there’s input lag. So far this is the only thing that’s laggy; dragging around parts, resizing, etc is all normal.


After awhile, the script becomes laggy again in a separate editor.

The only fix really is to factory reset it.


But how does it happen? And is it a ROBLOX Bug? I just don’t feel like Factory Resetting my whole entire computer to fix a ROBLOX Bug is something I want to do. Anyone found a fix besides factory resetting?