Unions disappearing / turning invisible after creation

Working on a game for a client that included 24 fairly simple unions, upon publishing the game all unions have now disappeared, they still show in explorer however they are invisible. Attempting to de-union them causes the union to delete itself from the workspace as if it never existed.

No attempts to recover the data for these unions have yet been successful.

I can’t paste a repro here as it is a private client however I would be more than happy to privately DM one to an admin/engineer on request!

Working on: Windows 10

Related threads:


This is a common thing people call “corrupted unions”.

There never was a way to recover those besides making them from scratch.

You can reproduce those on any device. All you need is some luck. I’m pretty sure that there’s a team that’s dedicated to working on making unions better. As a workaround, I suggest using meshes/parts without unioning them instead.


I remembered seeing a Discord post about this, so I browsed my photos and found this:

From what I can tell, it would seem as if that’s your problem. LMK if this works (I have yet to test it)!


I made a post about this a few months ago. It’s just a general glitch. Roblox Studio Union Glitch..?

1 Like

Try copying everything and pasting it into a new world, it worked for me.

Edit: And you don’t have to make a model.

1 Like

This issue seems to have gotten much worse over the last few months.
#help-and-feedback:building-support is currently full of users with “invisible unions”, and new cases keep appearing.

Here’s a related topic that I’ve left a reply to that may apply to this case as well.

You may also want to refer to this as well for help with recovering your unions if it happens to you.


Managed to catch a log file from a Studio session where one of the unions I made experienced this issue.
I don’t think it’s likely to contain useful information, but I figured I should share it anyway since this is difficult to reproduce.

Here are the log files from a session where 1/3 unions died. The first time I saved this file was after I created the union that is now broken. I did not close Studio until all three unions were created and I had saved several times.

SessionWhereUnionBroke.txt (11.9 KB)
SessionAfterLoadingBrokenUnionFile.txt (9.7 KB)
UnionShadows.rbxl (20.4 KB)


Following a issue that was mentionned last year, as the post says, Using :SubtractAsync() can lead to the Union to still “exist”, except it is fully transparent while still having Transparency set to 0, and returns no error or any kind of feedback when this abnormal situation happens.

Example 1 : Union is here, the shape is correct (thanks to the texture we can see it being accurate), However, the Transparency is 0 and is still invisible, cannot be changed !

The bug doesn’t seems to appear AT ALL in Studio (used to appear very rarely a month ago, i cannot replicate it on Studio anymore) analysing over 300 :SubtractAsync()

Image : Many vents taken from the Map generator in studio “Play Solo” or “Run”, cannot encounter the issue even if map is extended x4.

It might be a minor mistake in the engine, because it turns out the Union “Collisions” are still present, i can enter the vent or the wall surface have the collisions works just fine.

Hard to estimate the % probability of the bug to appear, considering there was some situation where i could see it Transparent, but the other player didn’t, or vice-versa

Today i had another test where “both” users could see it transparent.

I’d say it have a 5% chance to occur.

It seems to be a light detail, but i firmly believe that, for a game, especially to set up a horror atmosphere, ruins heavily the immersion, i might be unable to do contents that are supposed to be hidden/discovered.

Game : Evasion Prototype - Roblox
(Access : Friends only) - request if cannot access (or need the map gen code source)
i can make mp4/gif upon request.

Laptop Specs
  • Intel Core i7-7700HQ (Quad-Core 2.8 GHz / 3.8 GHz Turbo - Cache 6 Mo)
  • Chipset Mobile Intel HM175 Express
  • Frequency Memory DDR4 2400 MHz
  • Graphic Card NVIDIA GeForce GTX 1050
  • RAM 16 GB

I also have this bug in my game. My game generates unions at run time, and this bug happens pretty much every time I generate the parts of my game - which consists of several unions. The way I’m having to combat it is put textures on the sides of the bricks, so they look like they aren’t invisible. Not ideal.

Here is a unanswered thread from June also discussing the problem more specifically:

in the end i just ended up saving the generated parts, and creating maps out of the already made unions

and hello boxing game friend :smiley:

This happened to be a lot but if fixes itself sometimes when i press undo then redo.

1 Like

This issue still doesn’t seem to have fixed. This error didn’t happen to me till I left studio and went back on now as you can see the union is transparent.

What it’s supposed to look like:

What it looks like:

I’ve tried to figure out how I can revert this bug I tried turning it negative then undo it, export it as an OBJ and rejoin studio. None of these have worked. The wooden plants have disappeared please ignore the change in metal and door handles on the second one the photo is before the update to the door.


Has also happened to me. Only happens to game that were saved to my computer though. On top of that, some unions (I believe if they were from the save before) will load, but the most recent ones do not. It’s a pain because it is not only glitching in studio; It also glitches like that in the actual game. I can still walk on it, and select it, but it is invisible. Hopefully this gets patched soon, as I use unions for very small details.

I’ve recently attempted to make something using CSGv1. Saved regularly to Roblox and come in the next day to see it has disappeared. And I’ve attempted remaking them. Then uploading them to roblox as an object but most cases turning it invisible. Is there a simple fix to this?

This is really annoying, I think Roblox should focus more on this problem. A lot of player’s are losing hours of work due to a bug in their self made studio.


This bug is causing me a lot of issues, especially with live CSG and is currently stopping me from making a really cool system, if Roblox were able to resolve this issue it would open so many doors to more advanced games on Roblox.


This issue is causing me a lot of problems too I recently made a boat model for a game im working on I published the game to roblox as I had to get off my pc for the night and in the morning the unions where invisible. Also, messing with the collisionfedelity crashes my studio ( The union issue also happened to every union I had in my game )

I have also experienced this issue. Even when saved as a model it is not able to separate the union - it just vanishes, so you’re stuck with a union you have to redo:

1 Like

This happens to me all the time, and drives me insane. I like working with unions, but the frequency with which they get corrupted makes them basically unusable.

My current workflow is: create union in Roblox, export it as .obj immediately so I don’t lose it, use Blender to bring the mesh back into Roblox so that I can turn it into a meshpart. This is a pretty quick and easy as long as the union isn’t so complicated that it requires additional work in Blender.

That isn’t a solution - separating it just destroys the instance entirely.


In my case, as I reported below, I need to use SubtractAsync, I need to create walls via Server Script, since the windows must be positioned in a flexible way, depending on the wall size.

So what now?
Do I have to remove this feature from my game?
Or how long should I wait until this bug is fixed?