Studio Crashes When Opening The Object Browser and What's New Menus While Editing Place

Reproduction Steps

All you have to do is open up the object browser and it immediately crashes while editing a place. This has started happening as of version 0.543.395.5430593.

Operating System: Windows 11 (64-Bit)
CPU: Intel(R) Core™ i7-9750H CPU @ 2.60GHz
GPUs: Intel(R) UHD Graphics 630 and NVIDIA GeForce GTX 1660 Ti

This is not related to the missing vcruntime140_1.dll file.

Expected Behavior

Roblox Studio does not crash at all when opening the browser or closing it.

Actual Behavior

Roblox Studio immediately crashes when opening the object browser in any way while you are editing a place. This includes the ribbon menu, context menu, object browser keybind, and even the + icon. Roblox Studio also crashes when closing it while a place is open, which makes it nearly impossible to be able to publish updates without a crash.


The only workaround is inviting an alternate account into Team Create that is not on the version of Roblox Studio that the other account is on. Reinstalling didn’t fix this issue for me. Opening a second Roblox Studio and opening a place on both allows Roblox Studio to work without issues.

Issue Area: Studio
Issue Type: Crashing
Impact: Very High
Frequency: Constantly
Date First Experienced: 2022-09-07 19:09:00 (-05:00)
Date Last Experienced: 2022-09-09 00:29:00 (-05:00)
A private message is associated with this bug report

Update #1

This is an issue that is across this update according to multiple users. If you are having this issue, it is suggested to use an alternate account for the time being that doesn’t have the update. I will be making sure to add what happens to others in this post. Please, share your feedback if you are experiencing this too. I want to include as many issues with this crash as possible. If you can, please specify the OS you are using (ex. Windows 10, Windows 11, Linux, or Mac) as I want to know if this is Windows-specific or not.

Update #2

I do see that some people are confusing this issue with another issue of a missing .dll file. This is not the case in this situation. Read above for more information. Thanks to @Outgram for a fix for the .dll problem if you have that issue.

(These are not fixes for my issue, but for a DLL issue)

Update #3

I have added a video above to show what my issue is for the people who are confused about what I mean by my issue. I hope this helps as I currently am still having the issue that is shown in the video.

Update #4

This is gonna be the last update for the post. @PoshKiwi has an update on the issue and an emergency update is planned to release on Monday.

Update #5

I know I said the last update would be my last, but I was updated back to the version that crashes on Roblox Studio. The issue has been brought back, but I can now use the Roblox Player.

Update #6

Opening a second Roblox Studio allows you to not crash when opening the menus!

Update #7

Just updated Roblox Studio today and the previous workaround doesn’t work for me anymore.

Update #8

Roblox Studio’s rendering is broken again with Direct3D11 failing to properly load the menus and having them crash. Now, I can’t stream Roblox Studio directly to Discord whenever I want to show my friends what I am doing without sharing my entire screen and having no audio. I hope that this issue gets fixed.


Does this happen for you when you open the whats new window (bell in the top right corner). Or when you open the embedded insert object widget (Ribbon->Model->InsertObject)?
And if I understand you correctly when you click the + icon you crash immediately?
Can you also please post the version number of your Studio (File->About)
Please confirm the username you are developing with is ( HunterDaFloofer ) and I will move you off this build

If others are also seeing this issue please respond in thread.


Does this happen for you when you open the whats new window (bell in the top right corner). Or when you open the embedded insert object widget (Ribbon->Model->InsertObject)?

It does not crash when opening the Whats New window, only the InsertObject menu. I am certain it has to do with the new icons.

And if I understand you correctly when you click the + icon you crash immediately?

Yes, it does crash immediately when clicking the + icon, even when you press the InsertObject button in the context menu.

Please confirm the username you are developing with is ( HunterDaFloofer ) and I will move you off this build

Yep, I am HunterDaFloofer (@Hunterk1241), and I am using version 0.543.395.5430593 (64bit)

Thank you for helping me get off this version as I can’t work on my games at all with this issue.


Ok I removed you from the channel. You should see an update banner in the ribbon which will take you off this version of studio. Or you can close Studio and redownload from the website.
Thank you for reporting this issue, and sending in logs with your report. if you also have any .dmp files you could send that would also be immensely helpful in debugging this issue How to post a Bug Report - #13 by Roblox.


Turns out the What’s New menu is now crashing


How long does it usually take for me to be able to revert to a different version of Roblox Studio? I don’t see any update banner at all currently and the issues continue to be a problem.


Should only take a minute or 2. If you don’t already see the banner try opening studio via the Create - Roblox start creating button. No need to uninstall


It has been 30 minutes and I still have the same version with the problems that I mentioned above. I have tried opening from the create page to only be in the same version again. The PC I am using Roblox Studio on even crashed when closing it


Gah, there is something off about the unenrollment process, will send you a DM


I am experiencing the same issue. Is there any way to revert studio versions?


At the current moment, only Roblox administrators are able to. However, a solution that could be used for now is using an alternate account without the new update using Team Create. I do hope that the issues brought up are able to be fixed!

I am currently working with @PoshKiwi (in DMs) the best I can to get this sorted out


Unfortunate, but thanks for the tip. Hopefully this issue can be resolved soon.


I’m also facing this issue, Roblox studio crashes when I try to add an object


This seems to be an update-wide issue. I am hoping this gets patched or we get the update reversed until the version is fixed.


For everyone experiencing this issue, what system are you using that this issue appears on? I am asking in case this happens on different systems.


I’m having a similar issue that could be related to OP’s post. My studio crashes immediately when launched with an error message saying that some file is missing. I’ve tried reinstalling studio with no effect. I’m using a Windows 10 desktop.


Can you provide the error message itself in case it could be useful for Roblox staff?

1 Like

This is what I get when I launch studio. Pressing ‘OK’ makes the message reappear four times before disappearing.

That seems to be a missing DLL file that is required to open Roblox Studio, which is different from the post. However, I do think this post from the Microsoft website may help. vcruntime140_1.dll was not found - Microsoft Q&A


My studio just completely freezes if I want to add an object. To the point where I have to completely restart studio and start a new game and lose all my previous work